summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-12 07:29:21 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-12 07:29:21 +0000
commit09d732114e3cf504fa1e97d4a4f28684dbaf601b (patch)
tree6f5be1b00d031176cc98ed7e0cb60a722ca3c831 /net-misc/lambdamoo/lambdamoo-1.8.1-r1.ebuild
parentlicense for blackshades (diff)
downloadhistorical-09d732114e3cf504fa1e97d4a4f28684dbaf601b.tar.gz
historical-09d732114e3cf504fa1e97d4a4f28684dbaf601b.tar.bz2
historical-09d732114e3cf504fa1e97d4a4f28684dbaf601b.zip
fixes #24327
Diffstat (limited to 'net-misc/lambdamoo/lambdamoo-1.8.1-r1.ebuild')
-rw-r--r--net-misc/lambdamoo/lambdamoo-1.8.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/lambdamoo/lambdamoo-1.8.1-r1.ebuild b/net-misc/lambdamoo/lambdamoo-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..ae6c5ccc671e
--- /dev/null
+++ b/net-misc/lambdamoo/lambdamoo-1.8.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/lambdamoo/lambdamoo-1.8.1-r1.ebuild,v 1.1 2003/07/12 07:29:18 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="networked mud that can be used for different types of collaborative software"
+HOMEPAGE="http://sourceforge.net/projects/lambdamoo/"
+SRC_URI="mirror://sourceforge.net/lambdamoo/LambdaMOO-${PV}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-devel/bison"
+
+S=${WORKDIR}/MOO-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-enable-outbound.patch
+}
+
+src_compile() {
+ econf || die
+ emake CFLAGS="${CFLAGS} -DHAVE_MKFIFO=1" || die
+}
+
+src_install() {
+ dosbin moo
+ insinto /usr/share/${PN}
+ doins Minimal.db
+ dodoc *.txt README*
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/lambdamoo.rc lambdamoo
+ insinto /etc/conf.d ; newins ${FILESDIR}/lambdamoo.conf lambdamoo
+}