summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-02-11 22:27:50 +0000
committerZack Welch <zwelch@gentoo.org>2003-02-11 22:27:50 +0000
commit6a60ec34742c3a5ea7cd948fb7499f6312db89f5 (patch)
tree1413820f83103de52e977ebf2d0b2f485e068e38 /net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
parentAdded hppa to keywords. (diff)
downloadhistorical-6a60ec34742c3a5ea7cd948fb7499f6312db89f5.tar.gz
historical-6a60ec34742c3a5ea7cd948fb7499f6312db89f5.tar.bz2
historical-6a60ec34742c3a5ea7cd948fb7499f6312db89f5.zip
add new net-msc/netpipe ebuild (~arch masked)
Diffstat (limited to 'net-misc/netpipe/netpipe-1.0.0_beta2.ebuild')
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..5b35222fdbdd
--- /dev/null
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# Distributed under the terms of the GNU General Public License v2
+# ebuild created by Matthias Schwarzott <zzam@gmx.de>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild,v 1.1 2003/02/11 22:27:50 zwelch Exp $
+
+IUSE=""
+
+DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
+
+SRC_URI="http://home.t-online.de/home/gerd.o/netpipe.tar.gz"
+HOMEPAGE="http://home.t-online.de/home/gerd.o/netpipe.html"
+
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/netpipe"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s:^OPT=.*:OPT = ${CFLAGS}:" \
+ -e "s:^#CC.*:CC = gcc:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install () {
+ dobin netpipe
+ dodoc DOCUMENTATION INSTALL TECH-NOTES
+}