summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-04-09 15:35:48 +0000
committerDaniel Drake <dsd@gentoo.org>2005-04-09 15:35:48 +0000
commit8fd5cb7068067754904b3e267b489387affeb2fc (patch)
tree1ca67f49add31dedc2774c52132e1021f128e586 /net-misc/pavuk
parentAdded ~ppc64 to KEYWORDS (diff)
downloadhistorical-8fd5cb7068067754904b3e267b489387affeb2fc.tar.gz
historical-8fd5cb7068067754904b3e267b489387affeb2fc.tar.bz2
historical-8fd5cb7068067754904b3e267b489387affeb2fc.zip
Disable socks support due to brokenness
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-misc/pavuk')
-rw-r--r--net-misc/pavuk/ChangeLog5
-rw-r--r--net-misc/pavuk/Manifest10
-rw-r--r--net-misc/pavuk/pavuk-0.9.32.ebuild9
3 files changed, 13 insertions, 11 deletions
diff --git a/net-misc/pavuk/ChangeLog b/net-misc/pavuk/ChangeLog
index a2bc8473dc17..2a699cedb16f 100644
--- a/net-misc/pavuk/ChangeLog
+++ b/net-misc/pavuk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/pavuk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.20 2005/04/09 14:42:18 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.21 2005/04/09 15:35:48 dsd Exp $
+
+ 09 Apr 2005; Daniel Drake <dsd@gentoo.org> pavuk-0.9.32.ebuild:
+ Disable socks support due to brokenness
09 Apr 2005; Daniel Drake <dsd@gentoo.org> pavuk-0.9.32.ebuild:
Fix sandbox violation on USE=nls
diff --git a/net-misc/pavuk/Manifest b/net-misc/pavuk/Manifest
index 4feacba5ba7f..626a06d1a3fd 100644
--- a/net-misc/pavuk/Manifest
+++ b/net-misc/pavuk/Manifest
@@ -1,8 +1,8 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 0b9f43c1ae29688a29a3b06b13e92ee8 pavuk-0.9.32.ebuild 1432
-MD5 2d447495d4c40a15d0125aa9f1330480 ChangeLog 3161
+MD5 591bffe7aff55c3d0d3da385b15d1bd9 pavuk-0.9.32.ebuild 1385
+MD5 ce4a412cbf8134ce8d9e80239e12707b ChangeLog 3270
MD5 a1457284faaa66902037dcd2eaeab292 metadata.xml 245
MD5 af5ba7d3c10514dc10923b250eee99c9 pavuk-0.9.31.ebuild 1424
MD5 0ecaaa14f3190993e307fea1f2d880d3 files/digest-pavuk-0.9.31 65
@@ -10,7 +10,7 @@ MD5 452e79ff147b4c40cfee016d4c88c3bc files/digest-pavuk-0.9.32 65
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCV+nQiJcSIUGNthERAnVhAJ9ZhQkUh6vxwExg96ZbZFRapSLYzgCfetrX
-HKKXFd/VKGv7GEYqdo7taNo=
-=0jnx
+iD8DBQFCV/aCiJcSIUGNthERAuGxAKC0LaHVUqT7pVY5K4NOc2uniLHZXgCgsoTP
+tSaflul4oS21awzfOLbXipA=
+=tILU
-----END PGP SIGNATURE-----
diff --git a/net-misc/pavuk/pavuk-0.9.32.ebuild b/net-misc/pavuk/pavuk-0.9.32.ebuild
index a7874bf2e8c9..9d676e4204f4 100644
--- a/net-misc/pavuk/pavuk-0.9.32.ebuild
+++ b/net-misc/pavuk/pavuk-0.9.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.32.ebuild,v 1.3 2005/04/09 14:42:18 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.32.ebuild,v 1.4 2005/04/09 15:35:48 dsd Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc x86"
-IUSE="ssl X gnome mozilla socks5 nls"
+IUSE="ssl X gnome mozilla nls"
DEPEND=">=sys-apps/sed-4
sys-devel/gettext
@@ -19,19 +19,18 @@ DEPEND=">=sys-apps/sed-4
ssl? ( dev-libs/openssl )
X? ( virtual/x11 )
gnome? ( gnome-base/gnome-libs )
- mozilla? ( www-client/mozilla )
- socks5? ( net-misc/tsocks )"
+ mozilla? ( www-client/mozilla )"
src_compile() {
econf \
--enable-threads \
--with-regex=auto \
--disable-gtk \
+ --disable-socks \
$(use_with X x) \
$(use_enable ssl) \
$(use_enable gnome) \
$(use_enable mozilla js) \
- $(use_enable socks5 socks) \
$(use_enable nls) \
|| die "econf failed"