summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-02-24 05:25:23 +0000
committerDonny Davies <woodchip@gentoo.org>2003-02-24 05:25:23 +0000
commit4e334284bd1a8bd2d08ed1ee590286568980c7f4 (patch)
tree7d86a52e413a48087f714fb8b8e42b5efb247f98 /net-misc/rp-l2tp
parentsandbox violation fix (diff)
downloadhistorical-4e334284bd1a8bd2d08ed1ee590286568980c7f4.tar.gz
historical-4e334284bd1a8bd2d08ed1ee590286568980c7f4.tar.bz2
historical-4e334284bd1a8bd2d08ed1ee590286568980c7f4.zip
first checkin
Diffstat (limited to 'net-misc/rp-l2tp')
-rw-r--r--net-misc/rp-l2tp/ChangeLog8
-rw-r--r--net-misc/rp-l2tp/files/digest-rp-l2tp-0.31
-rw-r--r--net-misc/rp-l2tp/files/rp-l2tp-0.3-gentoo.diff251
-rw-r--r--net-misc/rp-l2tp/files/rp-l2tpd-init20
-rw-r--r--net-misc/rp-l2tp/rp-l2tp-0.3.ebuild34
5 files changed, 314 insertions, 0 deletions
diff --git a/net-misc/rp-l2tp/ChangeLog b/net-misc/rp-l2tp/ChangeLog
new file mode 100644
index 000000000000..a4c0154c8c5d
--- /dev/null
+++ b/net-misc/rp-l2tp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/rp-l2tp
+# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header:
+
+*rp-l2tp-0.3 (24 Feb 2003)
+
+ 24 Feb 2003; Donny Davies <woodchip@gentoo.org> :
+ Initial import, created by me.
diff --git a/net-misc/rp-l2tp/files/digest-rp-l2tp-0.3 b/net-misc/rp-l2tp/files/digest-rp-l2tp-0.3
new file mode 100644
index 000000000000..51dfc6264dbe
--- /dev/null
+++ b/net-misc/rp-l2tp/files/digest-rp-l2tp-0.3
@@ -0,0 +1 @@
+MD5 a8a7eb3ce8bb27af6ba280fd521c97cf rp-l2tp-0.3.tar.gz 191418
diff --git a/net-misc/rp-l2tp/files/rp-l2tp-0.3-gentoo.diff b/net-misc/rp-l2tp/files/rp-l2tp-0.3-gentoo.diff
new file mode 100644
index 000000000000..09c03b5c9363
--- /dev/null
+++ b/net-misc/rp-l2tp/files/rp-l2tp-0.3-gentoo.diff
@@ -0,0 +1,251 @@
+diff -uNr rp-l2tp-0.3.orig/Makefile.in rp-l2tp-0.3/Makefile.in
+--- rp-l2tp-0.3.orig/Makefile.in 2002-09-30 16:33:55.000000000 -0400
++++ rp-l2tp-0.3/Makefile.in 2003-02-23 23:34:23.000000000 -0500
+@@ -81,13 +81,13 @@
+
+ install: all
+ -mkdir -p $(RPM_INSTALL_ROOT)$(sbindir)
+- $(install) -m 755 -s l2tpd $(RPM_INSTALL_ROOT)$(sbindir)
+- -mkdir -p $(RPM_INSTALL_ROOT)/etc/l2tp
+- $(install) -m 644 l2tp.conf $(RPM_INSTALL_ROOT)/etc/l2tp/l2tp.conf.example
++ $(install) -m 755 -s l2tpd $(RPM_INSTALL_ROOT)$(sbindir)/rp-l2tpd
++ -mkdir -p $(RPM_INSTALL_ROOT)/etc/rp-l2tpd
++ $(install) -m 644 l2tp.conf $(RPM_INSTALL_ROOT)/etc/rp-l2tpd/rp-l2tpd.conf.example
+ -mkdir -p $(RPM_INSTALL_ROOT)$(mandir)/man8
+ -mkdir -p $(RPM_INSTALL_ROOT)$(mandir)/man5
+- $(install) -m 644 man/l2tpd.8 $(RPM_INSTALL_ROOT)$(mandir)/man8
+- $(install) -m 644 man/l2tp.conf.5 $(RPM_INSTALL_ROOT)$(mandir)/man5
++ $(install) -m 644 man/l2tpd.8 $(RPM_INSTALL_ROOT)$(mandir)/man8/rp-l2tpd.8
++ $(install) -m 644 man/l2tp.conf.5 $(RPM_INSTALL_ROOT)$(mandir)/man5/rp-l2tpd.conf.5
+
+ $(MAKE) -C handlers install
+
+diff -uNr rp-l2tp-0.3.orig/handlers/Makefile.in rp-l2tp-0.3/handlers/Makefile.in
+--- rp-l2tp-0.3.orig/handlers/Makefile.in 2002-09-30 15:45:00.000000000 -0400
++++ rp-l2tp-0.3/handlers/Makefile.in 2003-02-23 23:35:46.000000000 -0500
+@@ -39,7 +39,7 @@
+
+ install: all
+ -mkdir -p $(RPM_INSTALL_ROOT)$(sbindir)
+- -mkdir -p $(RPM_INSTALL_ROOT)$(prefix)/lib/l2tp/plugins
+- $(install) -m 755 -s l2tp-control $(RPM_INSTALL_ROOT)$(sbindir)
+- $(install) -m 755 $(HANDLERS) $(RPM_INSTALL_ROOT)$(prefix)/lib/l2tp/plugins
++ -mkdir -p $(RPM_INSTALL_ROOT)$(prefix)/lib/rp-l2tpd/plugins
++ $(install) -m 755 -s l2tp-control $(RPM_INSTALL_ROOT)$(sbindir)/rp-l2tpd-control
++ $(install) -m 755 $(HANDLERS) $(RPM_INSTALL_ROOT)$(prefix)/lib/rp-l2tpd/plugins
+ distclean: clean
+diff -uNr rp-l2tp-0.3.orig/handlers/cmd-control.c rp-l2tp-0.3/handlers/cmd-control.c
+--- rp-l2tp-0.3.orig/handlers/cmd-control.c 2002-09-30 15:45:00.000000000 -0400
++++ rp-l2tp-0.3/handlers/cmd-control.c 2003-02-23 23:38:44.000000000 -0500
+@@ -52,7 +52,7 @@
+
+ memset(&addr, 0, sizeof(addr));
+ addr.sun_family = AF_LOCAL;
+- strncpy(addr.sun_path, "/var/run/l2tpctrl", sizeof(addr.sun_path) - 1);
++ strncpy(addr.sun_path, "/var/run/rp-l2tpdctrl", sizeof(addr.sun_path) - 1);
+
+ fd = socket(AF_LOCAL, SOCK_STREAM, 0);
+ if (fd < 0) {
+diff -uNr rp-l2tp-0.3.orig/handlers/cmd.c rp-l2tp-0.3/handlers/cmd.c
+--- rp-l2tp-0.3.orig/handlers/cmd.c 2002-09-30 15:45:00.000000000 -0400
++++ rp-l2tp-0.3/handlers/cmd.c 2003-02-23 23:41:19.000000000 -0500
+@@ -162,7 +162,7 @@
+
+ /* We have hit the end of our options. Open command socket */
+ if (!sockname) {
+- sockname = "/var/run/l2tpctrl";
++ sockname = "/var/run/rp-l2tpdctrl";
+ }
+
+ (void) remove(sockname);
+diff -uNr rp-l2tp-0.3.orig/main.c rp-l2tp-0.3/main.c
+--- rp-l2tp-0.3.orig/main.c 2002-09-30 15:45:00.000000000 -0400
++++ rp-l2tp-0.3/main.c 2003-02-23 23:47:27.000000000 -0500
+@@ -27,7 +27,7 @@
+ static void
+ usage(int argc, char *argv[], int exitcode)
+ {
+- fprintf(stderr, "\nl2tpd Version %s Copyright 2002 Roaring Penguin Software Inc.\n", VERSION);
++ fprintf(stderr, "\nrp-l2tpd Version %s Copyright 2002 Roaring Penguin Software Inc.\n", VERSION);
+ fprintf(stderr, "http://www.roaringpenguin.com/\n\n");
+ fprintf(stderr, "Usage: %s [options]\n", argv[0]);
+ fprintf(stderr, "Options:\n");
+@@ -68,7 +68,7 @@
+ l2tp_peer_init();
+ l2tp_debug_set_bitmask(debugmask);
+
+- if (l2tp_parse_config_file(es, "/etc/l2tp/l2tp.conf") < 0) {
++ if (l2tp_parse_config_file(es, "/etc/rp-l2tpd/rp-l2tpd.conf") < 0) {
+ l2tp_die();
+ }
+
+diff -uNr rp-l2tp-0.3.orig/man/l2tp.conf.5 rp-l2tp-0.3/man/l2tp.conf.5
+--- rp-l2tp-0.3.orig/man/l2tp.conf.5 2002-09-30 16:20:28.000000000 -0400
++++ rp-l2tp-0.3/man/l2tp.conf.5 2003-02-23 23:57:22.000000000 -0500
+@@ -1,16 +1,16 @@
+ .\" $Id: rp-l2tp-0.3-gentoo.diff,v 1.1 2003/02/24 05:25:23 woodchip Exp $
+ .\" LIC: GPL
+-.TH L2TP.CONF 5 "11 March 2002"
++.TH RP-L2TPD.CONF 5 "11 March 2002"
+ .\""
+ .UC 4
+ .SH NAME
+-l2tp.conf \- L2TP configuration file
++rp-l2tpd.conf \- RP-L2TPD configuration file
+
+ .SH DESCRIPTION
+-\fBl2tpd\fR is a user-space L2TP daemon. L2TP is the Layer Two
++\fBrp-l2tpd\fR is a user-space L2TP daemon. L2TP is the Layer Two
+ Tunneling Protocol described in RFC 2661. It allows you to tunnel
+ PPP sessions over a network or transport protocol (in this case, UDP.)
+-The file \fB/etc/l2tp/l2tp.conf\fR is the configuration file for the
++The file \fB/etc/rp-l2tpd/rp-l2tpd.conf\fR is the configuration file for the
+ daemon.
+
+ Each line in the file takes one of the following forms:
+@@ -152,7 +152,7 @@
+ .TP
+ \fBo\fR socket-path \fIpathname\fR
+ Specifies the path name of the UNIX-domain socket for controlling the
+-daemon. Defaults to \fI/var/run/l2tpctrl\fR.
++daemon. Defaults to \fI/var/run/rp-l2tpdctrl\fR.
+
+ .PP
+ Even if you do not supply any options to cmd, you \fImust\fR have
+@@ -161,30 +161,30 @@
+ .SH CONTROLLING THE DAEMON
+
+ If you load the \fBcmd.so\fR handler, you can control the daemon
+-with a special program called \fBl2tp-control\fR. Here are the
++with a special program called \fBrp-l2tpd-control\fR. Here are the
+ available commands:
+
+ .TP
+-\fBo\fR l2tp-control "exit"
++\fBo\fR rp-l2tpd-control "exit"
+ Causes the daemon to terminate all sessions and tunnels, and exit.
+
+ .TP
+-\fBo\fR l2tp-control "start-session \fIpeer\fR"
++\fBo\fR rp-l2tpd-control "start-session \fIpeer\fR"
+ Causes the daemon to start a session with the specified peer.
+ The tunnel ID and session ID are printed if the session is successfully
+ started.
+
+ .TP
+-\fBo\fR l2tp-control "stop-session \fItunnel_id\fR \fIsession_id\fR"
++\fBo\fR rp-l2tpd-control "stop-session \fItunnel_id\fR \fIsession_id\fR"
+ Terminates the specified session.
+
+ .TP
+-\fBo\fR l2tp-control "dump-sessions"
++\fBo\fR rp-l2tpd-control "dump-sessions"
+ Dumps a list of sessions to standard-output.
+
+
+
+
+ .SH AUTHORS
+-\fBl2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
++\fBrp-l2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
+
+diff -uNr rp-l2tp-0.3.orig/man/l2tpd.8 rp-l2tp-0.3/man/l2tpd.8
+--- rp-l2tp-0.3.orig/man/l2tpd.8 2002-09-30 15:45:00.000000000 -0400
++++ rp-l2tp-0.3/man/l2tpd.8 2003-02-24 00:00:48.000000000 -0500
+@@ -1,14 +1,14 @@
+-.\" $Id: rp-l2tp-0.3-gentoo.diff,v 1.1 2003/02/24 05:25:23 woodchip Exp $
++.\" $Id: rp-l2tp-0.3-gentoo.diff,v 1.1 2003/02/24 05:25:23 woodchip Exp $
+ .\" LIC: GPL
+-.TH L2TPD 8 "11 March 2002"
++.TH RP-L2TPD 8 "11 March 2002"
+ .UC 4
+ .SH NAME
+-l2tpd \- user-space L2TP daemon.
++rp-l2tpd \- user-space L2TP daemon.
+ .SH SYNOPSIS
+-.B l2tpd \fR[\fIoptions\fR]
++.B rp-l2tpd \fR[\fIoptions\fR]
+
+ .SH DESCRIPTION
+-\fBl2tpd\fR is a user-space L2TP daemon. L2TP is the Layer Two
++\fBrp-l2tpd\fR is a user-space L2TP daemon. L2TP is the Layer Two
+ Tunneling Protocol described in RFC 2661. It allows you to tunnel
+ PPP sessions over a network or transport protocol (in this case, UDP.)
+
+@@ -16,50 +16,50 @@
+ .TP
+ .B \-d \fInum\fR
+ Sets the debug level to \fInum\fR. Of interest mostly to
+-\fBl2tpd\fR developers. \fInum\fR is a bitmask; set it to
++\fBrp-l2tpd\fR developers. \fInum\fR is a bitmask; set it to
+ 65535 for maximum debugging information.
+
+ .TP
+ .B \-f
+-Do not fork. Normally, \fBl2tpd\fR forks and puts itself in the
++Do not fork. Normally, \fBrp-l2tpd\fR forks and puts itself in the
+ background. This option causes it to stay running in the foreground.
+
+ .SH L2TPD ARCHITECTURE
+
+-The \fBl2tpd\fR program itself contains \fIonly\fR code necessary
++The \fBrp-l2tpd\fR program itself contains \fIonly\fR code necessary
+ for processing L2TP datagrams and maintaining L2TP tunnels and
+ sessions. It does \fInot\fR contain code for interacting with
+ \fBpppd\fR or for users to control session establishment and teardown.
+ These functions are performed by \fIhandlers\fR, which are
+ shared-object libraries dynamically loaded at run-time.
+ .PP
+-The handlers currently distributed with \fBl2tpd\fR include:
++The handlers currently distributed with \fBrp-l2tpd\fR include:
+ .TP
+ .B sync-pppd.so
+-A shared-library which interfaces with \fBpppd\fR and allows \fBl2tpd\fR
++A shared-library which interfaces with \fBpppd\fR and allows \fBrp-l2tpd\fR
+ to act as both an LAC and an LNS.
+ .TP
+ .B cmd.so
+ A simple command-interpreter which listens on a UNIX-domain socket
+ and allows you to start and stop L2TP sessions.
+ .PP
+-\fBl2tpd\fR is a single-threaded, event-driven program. It should be
++\fBrp-l2tpd\fR is a single-threaded, event-driven program. It should be
+ fairly lightweight and efficient.
+
+-.SH L2TPD CONFIGURATION
+-On startup, \fBl2tpd\fR reads the configuration file \fB/etc/l2tp/l2tp.conf\fR.
+-This configuration file sets operating parameters, describes peers and loads
+-and configures handlers. See \fBl2tp.conf\fR(5) for configuration
+-file details.
++.SH RP-L2TPD CONFIGURATION
++On startup, \fBrp-l2tpd\fR reads the configuration file
++\fB/etc/rp-l2tpd/rp-l2tpd.conf\fR. This configuration file sets operating
++parameters, describes peers and loads and configures handlers. See
++\fBrp-l2tpd.conf\fR(5) for configuration file details.
+
+ .SH FILES
+ .TP
+-.B /etc/l2tp/l2tp.conf
++.B /etc/rp-l2tpd/rp-l2tpd.conf
+ Main configuration file.
+ .TP
+-.B /var/run/l2tpctrl
++.B /var/run/rp-l2tpdctrl
+ Control socket for \fBcmd.so\fR handler.
+
+ .SH AUTHORS
+-\fBl2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
++\fBrp-l2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
+
+diff -uNr rp-l2tp-0.3.orig/utils.c rp-l2tp-0.3/utils.c
+--- rp-l2tp-0.3.orig/utils.c 2002-09-30 15:45:00.000000000 -0400
++++ rp-l2tp-0.3/utils.c 2003-02-23 23:53:26.000000000 -0500
+@@ -196,7 +196,7 @@
+ if (*fname == '/') {
+ handle = dlopen(fname, RTLD_NOW);
+ } else {
+- snprintf(buf, sizeof(buf), "%s/lib/l2tp/plugins/%s", PREFIX, fname);
++ snprintf(buf, sizeof(buf), "%s/lib/rp-l2tpd/plugins/%s", PREFIX, fname);
+ buf[sizeof(buf)-1] = 0;
+ handle = dlopen(buf, RTLD_NOW);
+ }
diff --git a/net-misc/rp-l2tp/files/rp-l2tpd-init b/net-misc/rp-l2tp/files/rp-l2tpd-init
new file mode 100644
index 000000000000..4e965634a0c8
--- /dev/null
+++ b/net-misc/rp-l2tp/files/rp-l2tpd-init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting rp-l2tpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/rp-l2tpd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rp-l2tpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rp-l2tpd
+ eend $?
+}
diff --git a/net-misc/rp-l2tp/rp-l2tp-0.3.ebuild b/net-misc/rp-l2tp/rp-l2tp-0.3.ebuild
new file mode 100644
index 000000000000..ad17165ae0e5
--- /dev/null
+++ b/net-misc/rp-l2tp/rp-l2tp-0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="RP-L2TP is a user-space implementation of L2TP for Linux and other UNIX systems"
+HOMEPAGE="http://sourceforge.net/projects/rp-l2tp/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DEPEND="virtual/glibc"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ patch -p1 <${FILESDIR}/${P}-gentoo.diff || die
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make RPM_INSTALL_ROOT=${D} install || die
+
+ dodoc README
+ newdoc l2tp.conf rp-l2tpd.conf
+ cp -a libevent/Doc ${D}/usr/share/doc/${PF}/libevent
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rp-l2tpd-init rp-l2tpd
+}