summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-07-27 08:39:42 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-07-27 08:39:42 +0000
commit371db1d61bc3ddc669be54e77af468165959f861 (patch)
treea4413893f26accacdce59c45c9b5fd2f6ec4b693 /net-misc
parentStable on ppc wrt bug 232370 (diff)
downloadhistorical-371db1d61bc3ddc669be54e77af468165959f861.tar.gz
historical-371db1d61bc3ddc669be54e77af468165959f861.tar.bz2
historical-371db1d61bc3ddc669be54e77af468165959f861.zip
Fix to compile with gcc-4.3
Package-Manager: portage-2.2_rc3/cvs/Linux 2.6.26 i686
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/snitch/ChangeLog8
-rw-r--r--net-misc/snitch/files/snitch-0.0.1-gcc-4.3.patch11
-rw-r--r--net-misc/snitch/snitch-0.0.1.ebuild12
3 files changed, 27 insertions, 4 deletions
diff --git a/net-misc/snitch/ChangeLog b/net-misc/snitch/ChangeLog
index 9c31e75be633..e4dc49b7ff39 100644
--- a/net-misc/snitch/ChangeLog
+++ b/net-misc/snitch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/snitch
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/snitch/ChangeLog,v 1.9 2007/07/02 15:06:04 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/snitch/ChangeLog,v 1.10 2008/07/27 08:39:41 ford_prefect Exp $
+
+ 27 Jul 2008; Arun Raghavan <ford_prefect@gentoo.org>
+ +files/snitch-0.0.1-gcc-4.3.patch, snitch-0.0.1.ebuild:
+ Fix to compile with gcc-4.3
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> snitch-0.0.1.ebuild:
(QA) RESTRICT clean up.
diff --git a/net-misc/snitch/files/snitch-0.0.1-gcc-4.3.patch b/net-misc/snitch/files/snitch-0.0.1-gcc-4.3.patch
new file mode 100644
index 000000000000..200694b8ca55
--- /dev/null
+++ b/net-misc/snitch/files/snitch-0.0.1-gcc-4.3.patch
@@ -0,0 +1,11 @@
+diff -urNp snitch-0.0.1-orig/snitch.cpp snitch-0.0.1/snitch.cpp
+--- snitch-0.0.1-orig/snitch.cpp 2008-07-27 12:32:59.000000000 +0530
++++ snitch-0.0.1/snitch.cpp 2008-07-27 12:33:19.000000000 +0530
+@@ -16,6 +16,7 @@
+ #include <string>
+ #include <stdlib.h>
+ #include <ctype.h>
++#include <cstring>
+
+ using namespace std;
+
diff --git a/net-misc/snitch/snitch-0.0.1.ebuild b/net-misc/snitch/snitch-0.0.1.ebuild
index 4299b167774a..7eab154fe336 100644
--- a/net-misc/snitch/snitch-0.0.1.ebuild
+++ b/net-misc/snitch/snitch-0.0.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/snitch/snitch-0.0.1.ebuild,v 1.7 2007/07/02 15:06:04 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/snitch/snitch-0.0.1.ebuild,v 1.8 2008/07/27 08:39:41 ford_prefect Exp $
+
+inherit eutils
DESCRIPTION="Snitch is a powerful packetshaping utility that allows the user to easily harness the power of the Linux tc command to shape network traffic"
HOMEPAGE="http://snitch.sourceforge.net/"
@@ -18,6 +20,12 @@ RDEPEND="${DEPEND}
>=net-firewall/iptables-1.2.9-r1
sys-apps/iproute2"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+}
+
src_compile() {
emake || die "emake failed"
}