summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-04 14:39:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-04 14:39:53 +0000
commit53da098dbdd77a1807206b23aa7128854b10a9fb (patch)
treebd542d75d6639a053765ca07b90dfb60db2c35e4 /net-misc
parentAdded dev-php4 and dev-php5 categories (diff)
downloadhistorical-53da098dbdd77a1807206b23aa7128854b10a9fb.tar.gz
historical-53da098dbdd77a1807206b23aa7128854b10a9fb.tar.bz2
historical-53da098dbdd77a1807206b23aa7128854b10a9fb.zip
Added patch to fix wrong 'make' calls on Gentoo/FreeBSD.
Package-Manager: portage-2.0.51.22
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcp/ChangeLog6
-rw-r--r--net-misc/dhcp/Manifest11
-rw-r--r--net-misc/dhcp/dhcp-3.0.2.ebuild4
-rw-r--r--net-misc/dhcp/files/dhcp-3.0.2-gmake.patch66
4 files changed, 80 insertions, 7 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index f12cc8229b5d..94ac2d19448e 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.55 2005/09/04 00:03:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.56 2005/09/04 14:39:53 flameeyes Exp $
+
+ 04 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/dhcp-3.0.2-gmake.patch, dhcp-3.0.2.ebuild:
+ Added patch to fix wrong 'make' calls on Gentoo/FreeBSD.
04 Sep 2005; Diego Pettenò <flameeyes@gentoo.org> dhcp-3.0.2.ebuild:
Remove -Werror cflag that is passed when building on FreeBSD to fix
diff --git a/net-misc/dhcp/Manifest b/net-misc/dhcp/Manifest
index 09a75bfdf906..73634b89de91 100644
--- a/net-misc/dhcp/Manifest
+++ b/net-misc/dhcp/Manifest
@@ -2,9 +2,10 @@
Hash: SHA1
MD5 d8087c6a781a978ccc4c5bc0e9b2fde0 dhcp-3.0.1-r1.ebuild 3992
-MD5 9959ef147ab31186d39109efb9ca0cae dhcp-3.0.2.ebuild 4097
-MD5 6b02fbca23d47791aeda119fd4444f39 ChangeLog 9262
+MD5 fd2864f5391129944f46c46c99fd1560 dhcp-3.0.2.ebuild 4135
+MD5 37786c0783706bbb8e94e9202b425d63 ChangeLog 9427
MD5 9384ae7ba3e9f56b8027ea92f607042d metadata.xml 215
+MD5 d0f61288e81ce020573f3f6965af8489 files/dhcp-3.0.2-gmake.patch 1872
MD5 8a19dd005c33231e02c03659f0c658df files/dhcrelay.rc6 626
MD5 323228061719fcac86be97a1a25d23b6 files/digest-dhcp-3.0.1-r1 128
MD5 6c69efa2b41915ec59e53bb065ac3d0c files/dhcrelay.conf 502
@@ -14,7 +15,7 @@ MD5 b060506f226297b90435f270b7345496 files/digest-dhcp-3.0.2 128
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDGjngj5H05b2HAEkRAnk8AJ4rpnnMj+NeOXJ1/jNCAmC7jIQaFQCgj1IH
-9kstvTiNY6WxuHmgUeXbgh4=
-=2Di4
+iD8DBQFDGwdYj5H05b2HAEkRAnJjAJ9xf3x5o3NrYfs2DV5W+zuEC+6YXgCeINSG
+LzNetumuyPQPYu7gnzPMSJ0=
+=Vijj
-----END PGP SIGNATURE-----
diff --git a/net-misc/dhcp/dhcp-3.0.2.ebuild b/net-misc/dhcp/dhcp-3.0.2.ebuild
index b0c20ae0a9c1..ba56b11f7e65 100644
--- a/net-misc/dhcp/dhcp-3.0.2.ebuild
+++ b/net-misc/dhcp/dhcp-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.2.ebuild,v 1.4 2005/09/04 00:03:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.2.ebuild,v 1.5 2005/09/04 14:39:53 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -37,6 +37,8 @@ src_unpack() {
# FreeBSD doesn't like -Werror that is forced on
sed -i -e 's:-Werror::' Makefile.conf
+
+ epatch ${FILESDIR}/${P}-gmake.patch
}
src_compile() {
diff --git a/net-misc/dhcp/files/dhcp-3.0.2-gmake.patch b/net-misc/dhcp/files/dhcp-3.0.2-gmake.patch
new file mode 100644
index 000000000000..4ab99a2b71a9
--- /dev/null
+++ b/net-misc/dhcp/files/dhcp-3.0.2-gmake.patch
@@ -0,0 +1,66 @@
+Index: dhcp-3.0.2/Makefile
+===================================================================
+--- dhcp-3.0.2.orig/Makefile
++++ dhcp-3.0.2/Makefile
+@@ -33,7 +33,7 @@ all:
+ if [ ! -d work.$$sysname ]; then \
+ echo No build directory for $$sysname - please run ./configure.; \
+ else \
+- (cd work.$$sysname; make all); \
++ (cd work.$$sysname; $(MAKE) all); \
+ fi
+
+ install:
+@@ -41,7 +41,7 @@ install:
+ if [ ! -d work.$$sysname ]; then \
+ echo No build directory for $$sysname - please run ./configure.; \
+ else \
+- (cd work.$$sysname; make install); \
++ (cd work.$$sysname; $(MAKE) install); \
+ fi
+
+ depend:
+@@ -49,7 +49,7 @@ depend:
+ if [ ! -d work.$$sysname ]; then \
+ echo No build directory for $$sysname - please run ./configure.; \
+ else \
+- (cd work.$$sysname; make depend); \
++ (cd work.$$sysname; $(MAKE) depend); \
+ fi
+
+ clean:
+@@ -57,7 +57,7 @@ clean:
+ if [ ! -d work.$$sysname ]; then \
+ echo No build directory for $$sysname - please run ./configure.; \
+ else \
+- (cd work.$$sysname; make clean); \
++ (cd work.$$sysname; $(MAKE) clean); \
+ fi
+
+ realclean:
+@@ -65,7 +65,7 @@ realclean:
+ if [ ! -d work.$$sysname ]; then \
+ echo No build directory for $$sysname - please run ./configure.; \
+ else \
+- (cd work.$$sysname; make realclean); \
++ (cd work.$$sysname; $(MAKE) realclean); \
+ fi
+
+ distclean:
+@@ -73,7 +73,7 @@ distclean:
+ if [ ! -d work.$$sysname ]; then \
+ echo No build directory for $$sysname - please run ./configure.; \
+ else \
+- (cd work.$$sysname; make distclean); \
++ (cd work.$$sysname; $(MAKE) distclean); \
+ fi
+
+ links:
+@@ -81,6 +81,6 @@ links:
+ if [ ! -d work.$$sysname ]; then \
+ echo No build directory for $$sysname - please run ./configure.; \
+ else \
+- (cd work.$$sysname; make links); \
++ (cd work.$$sysname; $(MAKE) links); \
+ fi
+