summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-12-02 13:15:48 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-12-02 13:15:48 +0000
commitd41dc6820c8025c35698d37e6962128033575b12 (patch)
tree94b083bd033c63ba4c95a6f4a8d569fef71ca037 /net-nds
parentnew version (diff)
downloadhistorical-d41dc6820c8025c35698d37e6962128033575b12.tar.gz
historical-d41dc6820c8025c35698d37e6962128033575b12.tar.bz2
historical-d41dc6820c8025c35698d37e6962128033575b12.zip
new version
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.181
-rw-r--r--net-nds/openldap/openldap-2.0.18.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest-openldap-2.0.18 b/net-nds/openldap/files/digest-openldap-2.0.18
new file mode 100644
index 000000000000..a12aeec1c666
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.18
@@ -0,0 +1 @@
+MD5 b5d1e165d663f64e69e99e24b9d18c03 openldap-2.0.18.tgz 1560576
diff --git a/net-nds/openldap/openldap-2.0.18.ebuild b/net-nds/openldap/openldap-2.0.18.ebuild
new file mode 100644
index 000000000000..bbcc359f513a
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.18.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.18.ebuild,v 1.1 2001/12/02 13:15:48 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ use tcpd && myconf="${myconf} --enable-wrappers"
+ use ssl && myconf="${myconf} --with-tls"
+ use readline && myconf="${myconf} --with-readline"
+ use readline || myconf="${myconf} --without-readline"
+ use gdbm && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ use gdbm || myconf="${myconf} --disable-ldbm"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ ./configure --host=${CHOST} --enable-passwd --enable-shell \
+ --enable-shared --enable-static --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var/state --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/openldap ${myconf}
+ assert "bad configure"
+
+ make depend || die
+ make || die
+ cd tests ; make || die
+}
+
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap \
+ localstatedir=${D}/var/state mandir=${D}/usr/share/man \
+ libexecdir=${D}/usr/lib/openldap install
+ assert "install problem"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ dosed $i
+ done
+}