summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-23 00:41:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-23 00:41:29 +0000
commitd6071ca50bd51473268ba66a3b185c4db95da584 (patch)
tree90ddab12d56e696cc578cde59d302d6421c084e4 /net-news/liferea/liferea-1.7.1.ebuild
parentBump (diff)
downloadhistorical-d6071ca50bd51473268ba66a3b185c4db95da584.tar.gz
historical-d6071ca50bd51473268ba66a3b185c4db95da584.tar.bz2
historical-d6071ca50bd51473268ba66a3b185c4db95da584.zip
Bump, small dep fixups. Closes #289753
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'net-news/liferea/liferea-1.7.1.ebuild')
-rw-r--r--net-news/liferea/liferea-1.7.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-news/liferea/liferea-1.7.1.ebuild b/net-news/liferea/liferea-1.7.1.ebuild
new file mode 100644
index 000000000000..961c43426a2f
--- /dev/null
+++ b/net-news/liferea/liferea-1.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.7.1.ebuild,v 1.1 2009/10/23 00:41:29 patrick Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo/etc feeds"
+HOMEPAGE="http://liferea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus libnotify lua networkmanager"
+
+RDEPEND=">=x11-libs/gtk+-2.16.0:2
+ >=dev-libs/glib-2.16.0:2
+ >=x11-libs/pango-1.4.0
+ gnome-base/gconf:2
+ dev-libs/libunique
+ >=dev-libs/libxml2-2.6.27
+ >=dev-libs/libxslt-1.1.19
+ >=dev-db/sqlite-3.6.10:3
+ >=gnome-base/libglade-2
+ >=net-libs/libsoup-2.26.1:2.4
+ >=net-libs/webkit-gtk-1.1.7
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ lua? ( >=dev-lang/lua-5.1 )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ networkmanager? ( net-misc/networkmanager dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-sm
+ --disable-schemas-install
+ $(use_enable dbus)
+ $(use_enable networkmanager nm)
+ $(use_enable libnotify)
+ $(use_enable lua)"
+}