summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-01-20 13:25:35 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-01-20 13:25:35 +0000
commitbf2ba62f00ac3234cc3f72649b7d64e3f7528e69 (patch)
tree01822586c1ec7ff522826b80eef0a426253b3fd0 /net-nntp/newspost/newspost-2.1.1-r3.ebuild
parentStable for arm, wrt bug #451450 (diff)
downloadhistorical-bf2ba62f00ac3234cc3f72649b7d64e3f7528e69.tar.gz
historical-bf2ba62f00ac3234cc3f72649b7d64e3f7528e69.tar.bz2
historical-bf2ba62f00ac3234cc3f72649b7d64e3f7528e69.zip
Migrate to EAPI 5. Respect LDFLAGS wrt bug #335512.
Package-Manager: portage-2.1.11.43/cvs/Linux x86_64 Manifest-Sign-Key: 0x675D0D2C
Diffstat (limited to 'net-nntp/newspost/newspost-2.1.1-r3.ebuild')
-rw-r--r--net-nntp/newspost/newspost-2.1.1-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-nntp/newspost/newspost-2.1.1-r3.ebuild b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
new file mode 100644
index 000000000000..09d95ab06135
--- /dev/null
+++ b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/newspost-2.1.1-r3.ebuild,v 1.1 2013/01/20 13:25:15 kensington Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A usenet binary autoposter for unix"
+HOMEPAGE="http://newspost.unixcab.org/"
+SRC_URI="http://newspost.unixcab.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_prepare() {
+ # Should fix some problems with unexpected server replies, cf. bug 185468
+ epatch "${FILESDIR}"/${P}-nntp.patch
+ epatch "${FILESDIR}"/CAN-2005-0101.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+
+ sed -e "/-strip newspost/d" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBS="${LDFLAGS}" main
+}
+
+src_install () {
+ dobin newspost
+ doman man/man1/newspost.1
+ dodoc CHANGES README
+}