summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-07-06 18:18:55 +0000
committerNed Ludd <solar@gentoo.org>2004-07-06 18:18:55 +0000
commit4d75866f3ccd15ec6bd044f9ce2e627630326c8a (patch)
tree2422375af8fc3ce80e14a1344f05603a663bc506 /net-wireless/chillispot
parentFix for bug #56256 (diff)
downloadhistorical-4d75866f3ccd15ec6bd044f9ce2e627630326c8a.tar.gz
historical-4d75866f3ccd15ec6bd044f9ce2e627630326c8a.tar.bz2
historical-4d75866f3ccd15ec6bd044f9ce2e627630326c8a.zip
initial commit of chillispot captive portal/wireless LAN access point controller
Diffstat (limited to 'net-wireless/chillispot')
-rw-r--r--net-wireless/chillispot/ChangeLog11
-rw-r--r--net-wireless/chillispot/Manifest5
-rw-r--r--net-wireless/chillispot/chillispot-0.94.ebuild37
-rw-r--r--net-wireless/chillispot/files/chillispot-0.94-src.patch65
-rw-r--r--net-wireless/chillispot/files/digest-chillispot-0.941
-rw-r--r--net-wireless/chillispot/metadata.xml16
6 files changed, 135 insertions, 0 deletions
diff --git a/net-wireless/chillispot/ChangeLog b/net-wireless/chillispot/ChangeLog
new file mode 100644
index 000000000000..f8573397205f
--- /dev/null
+++ b/net-wireless/chillispot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-wireless/chillispot
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/chillispot/ChangeLog,v 1.1 2004/07/06 18:18:55 solar Exp $
+
+*chillispot-0.94 (06 Jul 2004)
+
+ 06 Jul 2004; <solar@gentoo.org> chillispot-0.94.ebuild, metadata.xml,
+ files/chillispot-0.94-src.patch:
+ initial commit of chillispot captive portal/wireless LAN access point
+ controller
+
diff --git a/net-wireless/chillispot/Manifest b/net-wireless/chillispot/Manifest
new file mode 100644
index 000000000000..b8f644ff3037
--- /dev/null
+++ b/net-wireless/chillispot/Manifest
@@ -0,0 +1,5 @@
+MD5 bc3dc40432fe27214cf588a3248dc520 chillispot-0.94.ebuild 879
+MD5 5c76bddb3be7470f4fadeead04e41e97 ChangeLog 443
+MD5 86dbc1c8f833da6ec3297a3ab4667c30 metadata.xml 651
+MD5 26d2ac4fac2590c68ffd003625f7994a files/chillispot-0.94-src.patch 2196
+MD5 034ae1319d1349b4aa3e6cea36d3f4db files/digest-chillispot-0.94 67
diff --git a/net-wireless/chillispot/chillispot-0.94.ebuild b/net-wireless/chillispot/chillispot-0.94.ebuild
new file mode 100644
index 000000000000..4dbab7a9f15d
--- /dev/null
+++ b/net-wireless/chillispot/chillispot-0.94.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/chillispot/chillispot-0.94.ebuild,v 1.1 2004/07/06 18:18:55 solar Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="ChilliSpot is an open source captive portal or wireless LAN access point controller."
+HOMEPAGE="http://www.chillispot.org"
+SRC_URI="http://www.chillispot.org/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~mips"
+IUSE="debug pic"
+
+DEPEND="virtual/libc >=sys-apps/sed-4*"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/${P}-src.patch
+}
+
+src_compile() {
+ local myconf
+ export CFLAGS
+
+ use pic && myconf="${myconf} --with-pic"
+
+ econf ${myconf} || die "FAILED: econf ${myconf}"
+ emake || die "FAILED: emake"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}
diff --git a/net-wireless/chillispot/files/chillispot-0.94-src.patch b/net-wireless/chillispot/files/chillispot-0.94-src.patch
new file mode 100644
index 000000000000..4b59fdc83c69
--- /dev/null
+++ b/net-wireless/chillispot/files/chillispot-0.94-src.patch
@@ -0,0 +1,65 @@
+diff -Nrup chillispot-0.94.orig/src/Makefile.am chillispot-0.94/src/Makefile.am
+--- chillispot-0.94.orig/src/Makefile.am 2004-04-02 18:55:11.000000000 +0000
++++ chillispot-0.94/src/Makefile.am 2004-07-06 16:33:23.000000000 +0000
+@@ -1,9 +1,9 @@
+ sbin_PROGRAMS = chilli
+
+-AM_CFLAGS = -O2 -D_GNU_SOURCE -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"' -ggdb -lcrypt
++AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -ansi -DSBINDIR='"$(sbindir)"'
+
+ chilli_SOURCES = chilli.c defs.h tun.c tun.h cmdline.c cmdline.h ippool.c ippool.h radius.h radius.c md5.c md5.h redir.h redir.c dhcp.c dhcp.h syserr.c syserr.h
+-
++chilli_LDFLAGS = -lcrypt
+
+
+
+diff -Nrup chillispot-0.94.orig/src/Makefile.in chillispot-0.94/src/Makefile.in
+--- chillispot-0.94.orig/src/Makefile.in 2004-06-21 20:28:06.000000000 +0000
++++ chillispot-0.94/src/Makefile.in 2004-07-06 16:34:05.000000000 +0000
+@@ -66,18 +66,26 @@ EXEEXT = @EXEEXT@
+ OBJEXT = @OBJEXT@
+ PATH_SEPARATOR = @PATH_SEPARATOR@
+ AMTAR = @AMTAR@
++AR = @AR@
+ AS = @AS@
+ AWK = @AWK@
+ CC = @CC@
++CXX = @CXX@
++CXXCPP = @CXXCPP@
+ DEPDIR = @DEPDIR@
+ DLLTOOL = @DLLTOOL@
+ ECHO = @ECHO@
++EGREP = @EGREP@
++F77 = @F77@
++GCJ = @GCJ@
++GCJFLAGS = @GCJFLAGS@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ OBJDUMP = @OBJDUMP@
+ PACKAGE = @PACKAGE@
+ RANLIB = @RANLIB@
++RC = @RC@
+ STRIP = @STRIP@
+ VERSION = @VERSION@
+ am__include = @am__include@
+@@ -85,9 +93,10 @@ am__quote = @am__quote@
+ install_sh = @install_sh@
+ sbin_PROGRAMS = chilli
+
+-AM_CFLAGS = -O2 -D_GNU_SOURCE -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"' -ggdb -lcrypt
++AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -ansi -DSBINDIR='"$(sbindir)"'
+
+ chilli_SOURCES = chilli.c defs.h tun.c tun.h cmdline.c cmdline.h ippool.c ippool.h radius.h radius.c md5.c md5.h redir.h redir.c dhcp.c dhcp.h syserr.c syserr.h
++chilli_LDFLAGS = -lcrypt
+ subdir = src
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
+@@ -101,7 +110,6 @@ am_chilli_OBJECTS = chilli.$(OBJEXT) tun
+ chilli_OBJECTS = $(am_chilli_OBJECTS)
+ chilli_LDADD = $(LDADD)
+ chilli_DEPENDENCIES =
+-chilli_LDFLAGS =
+
+ DEFS = @DEFS@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
diff --git a/net-wireless/chillispot/files/digest-chillispot-0.94 b/net-wireless/chillispot/files/digest-chillispot-0.94
new file mode 100644
index 000000000000..dff50d0e3dd4
--- /dev/null
+++ b/net-wireless/chillispot/files/digest-chillispot-0.94
@@ -0,0 +1 @@
+MD5 eceec7cd5c3de841393c84a9328f7e88 chillispot-0.94.tar.gz 285083
diff --git a/net-wireless/chillispot/metadata.xml b/net-wireless/chillispot/metadata.xml
new file mode 100644
index 000000000000..66a4c40f6b42
--- /dev/null
+++ b/net-wireless/chillispot/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>solar@gentoo.org</email>
+</maintainer>
+
+<longdescription>ChilliSpot is an open source captive portal or wireless
+LAN access point controller. It is used for authenticating users of a
+wireless LAN. It supports web based login which is today's standard for
+public HotSpots and it supports Wireless Protected Access (WPA) which is
+the standard of the future. Authentication, authorization and accounting
+(AAA) is handled by your favorite radius server.</longdescription>
+
+</pkgmetadata>