summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-08-22 12:51:11 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-08-22 12:51:11 +0000
commitcd4da30976e2d7258af3553c255f806c337c0c3f (patch)
tree23d3b1e80473a59a765251b17b34dc2f946b8afd /net-wireless/hostapd
parentVersion bump. (diff)
downloadhistorical-cd4da30976e2d7258af3553c255f806c337c0c3f.tar.gz
historical-cd4da30976e2d7258af3553c255f806c337c0c3f.tar.bz2
historical-cd4da30976e2d7258af3553c255f806c337c0c3f.zip
Version bump. Compile against headers installed by net-wireless/madwifi-driver instead of local snapshot.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-wireless/hostapd')
-rw-r--r--net-wireless/hostapd/ChangeLog10
-rw-r--r--net-wireless/hostapd/files/digest-hostapd-0.4.41
-rw-r--r--net-wireless/hostapd/files/hostapd-0.4.4-conf.d12
-rw-r--r--net-wireless/hostapd/files/hostapd-0.4.4-init.d50
-rw-r--r--net-wireless/hostapd/hostapd-0.4.4.ebuild108
5 files changed, 180 insertions, 1 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index d3b7e16a6ba2..267d022013c3 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.37 2005/08/16 12:36:10 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.38 2005/08/22 12:51:11 brix Exp $
+
+*hostapd-0.4.4 (22 Aug 2005)
+
+ 22 Aug 2005; Henrik Brix Andersen <brix@gentoo.org>
+ +files/hostapd-0.4.4-conf.d, +files/hostapd-0.4.4-init.d,
+ +hostapd-0.4.4.ebuild:
+ Version bump. Compile against headers installed by
+ net-wireless/madwifi-driver instead of local snapshot.
16 Aug 2005; Henrik Brix Andersen <brix@gentoo.org> ChangeLog:
Stable on x86.
diff --git a/net-wireless/hostapd/files/digest-hostapd-0.4.4 b/net-wireless/hostapd/files/digest-hostapd-0.4.4
new file mode 100644
index 000000000000..07f4a00f517f
--- /dev/null
+++ b/net-wireless/hostapd/files/digest-hostapd-0.4.4
@@ -0,0 +1 @@
+MD5 79810ff32f6f12a37dc7827ce18af533 hostapd-0.4.4.tar.gz 273112
diff --git a/net-wireless/hostapd/files/hostapd-0.4.4-conf.d b/net-wireless/hostapd/files/hostapd-0.4.4-conf.d
new file mode 100644
index 000000000000..40f9bd80fe93
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.4.4-conf.d
@@ -0,0 +1,12 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/files/hostapd-0.4.4-conf.d,v 1.1 2005/08/22 12:51:11 brix Exp $
+
+# List of interfaces which needs to be started before hostapd
+INTERFACES="wlan0"
+
+# List of configuration files
+CONFIGS="/etc/hostapd/hostapd.conf"
+
+# Extra options to pass to hostapd
+OPTIONS="-B"
diff --git a/net-wireless/hostapd/files/hostapd-0.4.4-init.d b/net-wireless/hostapd/files/hostapd-0.4.4-init.d
new file mode 100644
index 000000000000..29fa2fbf4a2c
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.4.4-init.d
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/files/hostapd-0.4.4-init.d,v 1.1 2005/08/22 12:51:11 brix Exp $
+
+opts="start stop reload"
+
+depend() {
+ local iface
+
+ for iface in ${INTERFACES}; do
+ need net.${iface}
+ done
+
+ use logger
+}
+
+checkconfig() {
+ local file
+
+ for file in ${CONFIGS}; do
+ if [[ ! -r ${file} ]]; then
+ eerror "hostapd configuration file (${CONFIG}) not found"
+ return 1
+ fi
+ done
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting hostapd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/hostapd \
+ -- ${OPTIONS} ${CONFIGS}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping hostapd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/hostapd
+ eend ${?}
+}
+
+reload() {
+ checkconfig || return 1
+
+ ebegin "Reloading hostapd configuration"
+ start-stop-daemon --stop --signal 1 --quiet --exec /usr/sbin/hostapd
+ eend ${?}
+}
diff --git a/net-wireless/hostapd/hostapd-0.4.4.ebuild b/net-wireless/hostapd/hostapd-0.4.4.ebuild
new file mode 100644
index 000000000000..eb2bfde13a8c
--- /dev/null
+++ b/net-wireless/hostapd/hostapd-0.4.4.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.4.4.ebuild,v 1.1 2005/08/22 12:51:11 brix Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="IEEE 802.11 wireless LAN Host AP daemon"
+HOMEPAGE="http://hostap.epitest.fi"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="ipv6 madwifi ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ madwifi? ( >=net-wireless/madwifi-driver-0.1_pre20050420-r1 )"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_unpack() {
+ local CONFIG=${S}/.config
+
+ unpack ${A}
+
+ sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
+ ${S}/hostapd.conf
+
+ # toolchain setup
+ echo "CC = $(tc-getCC)" > ${CONFIG}
+
+ # authentication methods
+ echo "CONFIG_EAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
+ echo "CONFIG_EAP_GTC=y" >> ${CONFIG}
+ echo "CONFIG_IAPP=y" >> ${CONFIG}
+ echo "CONFIG_PKCS12=y" >> ${CONFIG}
+ echo "CONFIG_RADIUS_SERVER=y" >> ${CONFIG}
+ echo "CONFIG_RSN_PREAUTH=y" >> ${CONFIG}
+ echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
+
+ if use ssl; then
+ # SSL authentication methods
+ echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PEAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TLS=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TTLS=y" >> ${CONFIG}
+ fi
+
+ if use ipv6; then
+ echo "CONFIG_IPV6=y" >> ${CONFIG}
+ fi
+
+ # Linux specific drivers
+ echo "CONFIG_DRIVER_HOSTAP=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_WIRED=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_PRISM54=y" >> ${CONFIG}
+
+ if use madwifi; then
+ # Add include path for madwifi-driver headers
+ echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ fi
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /etc/hostapd
+ doins hostapd.conf hostapd.accept hostapd.deny
+
+ dosbin hostapd
+ dobin hostapd_cli
+
+ newinitd ${FILESDIR}/${P}-init.d hostapd
+ newconfd ${FILESDIR}/${P}-conf.d hostapd
+
+ doman hostapd.8 hostapd_cli.1
+
+ dodoc ChangeLog developer.txt README
+
+ docinto examples
+ dodoc madwifi.conf wired.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "In order to use ${PN} you need to set up your wireless card"
+ einfo "for master mode in /etc/conf.d/net or /etc/conf.d/wireless"
+ einfo "and then start /etc/init.d/hostapd."
+ einfo
+ einfo "Example configuration:"
+ einfo
+ einfo "config_wlan0=( \"192.168.1.1/24\" )"
+ einfo "channel_wlan0=\"6\""
+ einfo "essid_wlan0=\"test\""
+ einfo "mode_wlan0=\"master\""
+ einfo
+ if use madwifi; then
+ einfo "This package now compiles against the headers installed by"
+ einfo "net-wireless/madwifi-driver. You should remerge ${PN} after"
+ einfo "upgrading net-wireless/madwifi-driver."
+ einfo
+ fi
+}