summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-04-28 23:00:37 +0000
committerStuart Herbert <stuart@gentoo.org>2004-04-28 23:00:37 +0000
commit63dbc3ca4ac35788b6c9b4546226792dd037be47 (patch)
tree1cab0004a92ad97704b32f3b29d759b82018caca /net-www/lighttpd
parentupdate profile (diff)
downloadhistorical-63dbc3ca4ac35788b6c9b4546226792dd037be47.tar.gz
historical-63dbc3ca4ac35788b6c9b4546226792dd037be47.tar.bz2
historical-63dbc3ca4ac35788b6c9b4546226792dd037be47.zip
Fix for bug #46833
Diffstat (limited to 'net-www/lighttpd')
-rw-r--r--net-www/lighttpd/ChangeLog8
-rw-r--r--net-www/lighttpd/Manifest6
-rw-r--r--net-www/lighttpd/files/digest-lighttpd-1.1.8-r11
-rw-r--r--net-www/lighttpd/files/lighttpd.initd4
-rw-r--r--net-www/lighttpd/lighttpd-1.1.8-r1.ebuild62
5 files changed, 76 insertions, 5 deletions
diff --git a/net-www/lighttpd/ChangeLog b/net-www/lighttpd/ChangeLog
index 406ab14576c2..b0b819650082 100644
--- a/net-www/lighttpd/ChangeLog
+++ b/net-www/lighttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/lighttpd
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/lighttpd/ChangeLog,v 1.5 2004/04/27 20:38:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lighttpd/ChangeLog,v 1.6 2004/04/28 23:00:37 stuart Exp $
+
+*lighttpd-1.1.8-r1 (29 Apr 2004)
+
+ 29 Apr 2004; Stuart Herbert <stuart@gentoo.org> lighttpd-1.1.8-r1.ebuild,
+ files/lighttpd.initd:
+ Fix for shutdown problems; see bug #46833
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> lighttpd-1.1.8.ebuild:
Add inherit eutils
diff --git a/net-www/lighttpd/Manifest b/net-www/lighttpd/Manifest
index 688f857275f0..67a1abb248de 100644
--- a/net-www/lighttpd/Manifest
+++ b/net-www/lighttpd/Manifest
@@ -1,6 +1,8 @@
MD5 58653fc1a55f58e5fea7860412023fee lighttpd-1.1.8.ebuild 1935
+MD5 a15b86b57bbfffd049407e96606e6620 ChangeLog 1185
MD5 3d182d43f7f0341a9a42f96694f04e72 metadata.xml 224
-MD5 d902ad73106ca33afd398e06a2dfec19 ChangeLog 1008
+MD5 563ae6b133c215471dde5143b00b4162 lighttpd-1.1.8-r1.ebuild 1936
MD5 eb94c0fc2149e2543beb50e93058de99 files/digest-lighttpd-1.1.8 66
MD5 352e2fac9cb73bdae7672f977b044894 files/lighttpd-1.1.8-gentoo.diff 1301
-MD5 b23bbb2c34588e8946e5f7858f3fa2db files/lighttpd.initd 638
+MD5 e0c149abb40a1adf883fe6c88c5237bc files/lighttpd.initd 638
+MD5 eb94c0fc2149e2543beb50e93058de99 files/digest-lighttpd-1.1.8-r1 66
diff --git a/net-www/lighttpd/files/digest-lighttpd-1.1.8-r1 b/net-www/lighttpd/files/digest-lighttpd-1.1.8-r1
new file mode 100644
index 000000000000..1b351f1c99d1
--- /dev/null
+++ b/net-www/lighttpd/files/digest-lighttpd-1.1.8-r1
@@ -0,0 +1 @@
+MD5 1f955ac35765a2630050a0cbf113d15f lighttpd-1.1.8.tar.gz 536169
diff --git a/net-www/lighttpd/files/lighttpd.initd b/net-www/lighttpd/files/lighttpd.initd
index a4234907e060..8b03a0b5a189 100644
--- a/net-www/lighttpd/files/lighttpd.initd
+++ b/net-www/lighttpd/files/lighttpd.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/lighttpd/files/lighttpd.initd,v 1.1 2004/04/23 17:30:26 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lighttpd/files/lighttpd.initd,v 1.2 2004/04/28 23:00:37 stuart Exp $
PID_FILE="/var/run/lighttpd.pid"
LIGHTTPD_BIN="/usr/sbin/lighttpd"
@@ -23,7 +23,7 @@ start() {
stop() {
ebegin "Stopping lighttpd"
- RET=$?
kill `cat ${PID_FILE}`
+ RET=$?
eend ${RET}
}
diff --git a/net-www/lighttpd/lighttpd-1.1.8-r1.ebuild b/net-www/lighttpd/lighttpd-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..a6a3defe41b8
--- /dev/null
+++ b/net-www/lighttpd/lighttpd-1.1.8-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/lighttpd/lighttpd-1.1.8-r1.ebuild,v 1.1 2004/04/28 23:00:37 stuart Exp $
+
+inherit eutils
+
+DESCRIPTION="lighttpd is intented to be a frontend for ad-servers which have to deliver small files concurrently to many connections."
+HOMEPAGE="http://jan.kneschke.de/projects/lighttpd"
+SRC_URI="http://jan.kneschke.de/projects/lighttpd/download/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="mysql ssl"
+DEPEND="virtual/glibc
+ >=dev-libs/libpcre-3.1
+ >=sys-libs/zlib-1.1
+ >=sys-devel/libtool-1.4
+ mysql? ( >=dev-db/mysql-4.0.0 )
+ ssl? ( >=dev-libs/openssl-0.9.7 )"
+RDEPEND=">=sys-libs/zlib-1.1
+ >=sys-devel/libtool-1.4
+ mysql? ( >=dev-db/mysql-4.0.0 )
+ ssl? ( >=dev-libs/openssl-0.9.7 )"
+S=${WORKDIR}/${P}
+LIGHTTPD_DIR="/var/www/localhost/htdocs/"
+LOG_DIR="/var/log/lighttpd/"
+
+pkg_setup() {
+ if ! grep -q ^lighttpd: /etc/passwd ; then
+ useradd -g nofiles -s /bin/false -d ${LIGHTTPD_DIR} \
+ -c "lighttpd" lighttpd || die "problem adding user lighttpd"
+ fi
+}
+
+src_compile() {
+ epatch ${FILESDIR}/lighttpd-1.1.8-gentoo.diff
+ if [ `use ssl` ]; then
+ USE_SSL="--with-openssl"
+ fi
+ econf --libdir=/usr/lib/${PN} \
+ `use_with mysql` \
+ ${USE_SSL} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README COPYING
+ newdoc doc/lighttpd.conf lighttpd.conf.example
+ dodoc doc/fastcgi.txt doc/authentification.txt
+ insinto /etc/conf.d/; doins doc/lighttpd.conf
+ exeinto /etc/init.d; newexe ${FILESDIR}/lighttpd.initd lighttpd
+ dodir ${LIGHTTPD_DIR} ${LOG_DIR}
+ chown lighttpd:root ${D}/${LOG_DIR}
+}
+
+pkg_postinst() {
+ einfo "In order to use fast-cgi for php you have to emerge dev-php/php-cgi and"
+ einfo "please read /usr/share/doc/lighttpd-1.1.8/fastcgi.txt.gz for more information"
+}