summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-10-15 05:05:29 +0000
committerChris White <chriswhite@gentoo.org>2004-10-15 05:05:29 +0000
commitf3a8d61476797e4831450d9ba1de024abddba3e4 (patch)
tree17d919e8ddbff2efc494c059828af5e4c6e3c133 /net-www/nvu
parentStable on sparc wrt security bug #66371. (diff)
downloadhistorical-f3a8d61476797e4831450d9ba1de024abddba3e4.tar.gz
historical-f3a8d61476797e4831450d9ba1de024abddba3e4.tar.bz2
historical-f3a8d61476797e4831450d9ba1de024abddba3e4.zip
Fixed ebuild to use the global entry for .desktop files. Fixed .mozconfig to use a more standard /usr/lib/nvu path, which also fixed the .desktop entry icon not showing.
Diffstat (limited to 'net-www/nvu')
-rw-r--r--net-www/nvu/ChangeLog8
-rw-r--r--net-www/nvu/Manifest6
-rw-r--r--net-www/nvu/files/.mozconfig1
-rw-r--r--net-www/nvu/nvu-0.50.ebuild20
4 files changed, 16 insertions, 19 deletions
diff --git a/net-www/nvu/ChangeLog b/net-www/nvu/ChangeLog
index 1d3e6e5f0803..f7a904317365 100644
--- a/net-www/nvu/ChangeLog
+++ b/net-www/nvu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/nvu
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/nvu/ChangeLog,v 1.1 2004/10/14 23:17:00 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/nvu/ChangeLog,v 1.2 2004/10/15 05:05:29 chriswhite Exp $
+
+ 15 Oct 2004; Chris White <chriswhite@gentoo.org> files/.mozconfig,
+ nvu-0.50.ebuild:
+ Fixed ebuild to use the global entry for .desktop files. Fixed .mozconfig to
+ use a more standard /usr/lib/nvu path, which also fixed the .desktop entry
+ icon not showing.
*nvu-0.50 (14 Oct 2004)
diff --git a/net-www/nvu/Manifest b/net-www/nvu/Manifest
index 97e38a241cd7..273517703f17 100644
--- a/net-www/nvu/Manifest
+++ b/net-www/nvu/Manifest
@@ -1,7 +1,7 @@
-MD5 bc61cc925d247769cbe0ca88da9aeff4 nvu-0.50.ebuild 1367
+MD5 52a45824687c3ef9c026ee40b6a9ce71 nvu-0.50.ebuild 1209
MD5 61e0760385f6cbd59f2e755773e22932 metadata.xml 226
-MD5 33ce65619be42a1e19656afb61766694 ChangeLog 512
-MD5 a2a4021bb009aff30f530f05e97611cd files/.mozconfig 2105
+MD5 a43a0a2d78bf27bc77ecbcb77cad83a1 ChangeLog 777
+MD5 804d8ace1834e359837a61cd14b800ae files/.mozconfig 2167
MD5 f04489cb980dbc4f22e78024f3e611e0 files/digest-nvu-0.50 71
MD5 aae073cc843ae213edb20559a512ee71 files/nvu-0.50-prefix.patch 331
MD5 4f757ecfc69252df6ebc3c62bb4713f1 files/nvu.desktop 182
diff --git a/net-www/nvu/files/.mozconfig b/net-www/nvu/files/.mozconfig
index 853f0494b3c2..152ff2522efc 100644
--- a/net-www/nvu/files/.mozconfig
+++ b/net-www/nvu/files/.mozconfig
@@ -59,3 +59,4 @@ ac_add_options --enable-freetype2
ac_add_options --enable-toolkit=gtk2
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-xft
+ac_add_options --with-default-mozilla-five-home=/usr/lib/nvu
diff --git a/net-www/nvu/nvu-0.50.ebuild b/net-www/nvu/nvu-0.50.ebuild
index ae67d6f7e533..8fd516d0dfa3 100644
--- a/net-www/nvu/nvu-0.50.ebuild
+++ b/net-www/nvu/nvu-0.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/nvu/nvu-0.50.ebuild,v 1.1 2004/10/14 23:17:00 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/nvu/nvu-0.50.ebuild,v 1.2 2004/10/15 05:05:29 chriswhite Exp $
inherit eutils mozilla flag-o-matic
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="kde gnome"
+IUSE=""
DEPEND="sys-apps/gawk
dev-lang/perl
app-doc/doxygen"
@@ -39,17 +39,7 @@ src_compile() {
src_install() {
make -f client.mk DESTDIR=${D} install || die
- #menu entry for gnome
- if use gnome
- then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/nvu.desktop
- fi
-
- #menu entry for kde
- if use kde
- then
- insinto /usr/share/applnk/Development
- doins ${FILESDIR}/nvu.desktop
- fi
+ #menu entry for gnome/kde
+ insinto /usr/share/applications
+ doins ${FILESDIR}/nvu.desktop
}