summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-05-27 22:24:43 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-05-27 22:24:43 +0000
commitd8b9ea6f458b8ebf4e591bcadb400181c6132e6c (patch)
tree322aa42a37c1d64164dd6d0540ce0aad8fce6886 /net-www
parentmasked gdkxft (diff)
downloadhistorical-d8b9ea6f458b8ebf4e591bcadb400181c6132e6c.tar.gz
historical-d8b9ea6f458b8ebf4e591bcadb400181c6132e6c.tar.bz2
historical-d8b9ea6f458b8ebf4e591bcadb400181c6132e6c.zip
new version
Diffstat (limited to 'net-www')
-rw-r--r--net-www/links/ChangeLog10
-rw-r--r--net-www/links/files/digest-links-2.0_pre41
-rw-r--r--net-www/links/links-2.0_pre4.ebuild82
3 files changed, 91 insertions, 2 deletions
diff --git a/net-www/links/ChangeLog b/net-www/links/ChangeLog
index 479695652428..7bf9b5b93a1e 100644
--- a/net-www/links/ChangeLog
+++ b/net-www/links/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for net-www/links
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.2 2002/05/26 15:07:58 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.3 2002/05/27 22:24:43 azarah Exp $
+
+*links-2.0_pre4 (27 May 2002)
+
+ 27 May 2002; Martin Schlemmer <azarah@gentoo.org> links-2.0_pre4.ebuild :
+
+ Version bump.
*links-2.0_pre3 (26 May 2002)
- 26 May 2002; Seemant Kulleen <seemant@gentoo.org> links-2.0_pre3.ebuild
+ 26 May 2002; Seemant Kulleen <seemant@gentoo.org> links-2.0_pre3.ebuild :
files/digest-links-2.0_pre3 :
Version bump thanks to kamisama@free.fr (Defresne Sylvain (keiichi)) in
diff --git a/net-www/links/files/digest-links-2.0_pre4 b/net-www/links/files/digest-links-2.0_pre4
new file mode 100644
index 000000000000..3cb8d7b654be
--- /dev/null
+++ b/net-www/links/files/digest-links-2.0_pre4
@@ -0,0 +1 @@
+MD5 82ed8877ee508ab0a70429cd49a9ba68 links-2.0pre4.tar.bz2 3489525
diff --git a/net-www/links/links-2.0_pre4.ebuild b/net-www/links/links-2.0_pre4.ebuild
new file mode 100644
index 000000000000..9f05313c6488
--- /dev/null
+++ b/net-www/links/links-2.0_pre4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Defresne Sylvain (keiichi) <kamisama@free.fr>
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.0_pre4.ebuild,v 1.1 2002/05/27 22:24:43 azarah Exp $
+
+DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
+LICENSE="GPL-2"
+
+# To handle pre-version ...
+MYP="${P/_/}"
+S="${WORKDIR}/${MYP}"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( >=sys-libs/gpm-1.20.0 )
+ java? ( >=sys-devel/flex-2.5.4a )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3 )
+ X? ( virtual/x11 )"
+
+src_compile ()
+{
+ local myconf
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use png \
+ && myconf="${myconf} --enable-graphics --with-libpng" \
+ || myconf="${myconf} --disable-graphics --without-libpng"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ use svga \
+ && myconf="${myconf} --with-svgalib" \
+ || myconf="${myconf} --without-svgalib"
+
+ use fbcon \
+ && myconf="${myconf} --with-fb" \
+ || myconf="${myconf} --without-fb"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use java \
+ && myconf="${myconf} --enable-javascript" \
+ || myconf="${myconf} --disable-javascript"
+
+ # ./configure only support 'gpm' features auto-detection, so if
+ # 'sys-libs/gpm' is compiled on your system, you'll compile links
+ # with gpm support ...
+
+ econf ${myconf} || die
+ emake || die "make failed"
+}
+
+src_install ()
+{
+ einstall || die "make install failed"
+
+ # Only install links icon if X driver was compiled in ...
+ use X && ( \
+ insinto /usr/share/pixmaps
+ doins graphics/links.xpm
+ )
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES TODO
+ dohtml doc/links_cal/*
+}