summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-01 05:20:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-01 05:20:11 +0000
commit3010a979efd790a856dde6be21ff3038f476e4eb (patch)
tree791332b7afde01a5efc230d99e2e36cc55a812f8 /net-zope
parentInitial addition. (diff)
downloadhistorical-3010a979efd790a856dde6be21ff3038f476e4eb.tar.gz
historical-3010a979efd790a856dde6be21ff3038f476e4eb.tar.bz2
historical-3010a979efd790a856dde6be21ff3038f476e4eb.zip
Initial addition.
Package-Manager: portage-14770-svn/cvs/Linux x86_64
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope-authentication/ChangeLog10
-rw-r--r--net-zope/zope-authentication/Manifest4
-rw-r--r--net-zope/zope-authentication/metadata.xml6
-rw-r--r--net-zope/zope-authentication/zope-authentication-3.7.0.ebuild34
4 files changed, 54 insertions, 0 deletions
diff --git a/net-zope/zope-authentication/ChangeLog b/net-zope/zope-authentication/ChangeLog
new file mode 100644
index 000000000000..c61f800362f7
--- /dev/null
+++ b/net-zope/zope-authentication/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-authentication
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-authentication/ChangeLog,v 1.1 2009/11/01 05:20:11 arfrever Exp $
+
+*zope-authentication-3.7.0 (01 Nov 2009)
+
+ 01 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-authentication-3.7.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-authentication/Manifest b/net-zope/zope-authentication/Manifest
new file mode 100644
index 000000000000..37cf577099e7
--- /dev/null
+++ b/net-zope/zope-authentication/Manifest
@@ -0,0 +1,4 @@
+DIST zope.authentication-3.7.0.tar.gz 9504 RMD160 62f394d86c5ad9994c409da0379d35ffe7f0c3fe SHA1 c280a31f9b2d4868c786de291a577754875b1b44 SHA256 99c8a1f1a9a75ff621022e40b90e176b1c62c8a5a200d212cc0de2424b05b992
+EBUILD zope-authentication-3.7.0.ebuild 889 RMD160 7637cbb58e000810b48412e73f4d8d647e801967 SHA1 807420e906bbe6b55c9070781393ce60402a43b6 SHA256 588588ddc0cdae1a7705144400a4ed8fea8a5e3757318272509d2fa3b9746f6c
+MISC ChangeLog 441 RMD160 0a36fb4502e95c9643fe193a416a9a2f1429a3ef SHA1 54f2d76521a3b04f98127adc8cd5957e50347d0e SHA256 0bc3b98c3ca6f45fb6e4b73dc40bdb38971911b65407ac7fb3e9ba9944f79be8
+MISC metadata.xml 183 RMD160 0e2d86898897ee70cc1f6e9ceb76d00388d3b2fa SHA1 19635a9dfa15036e341a7cbdd8cbd018db62be82 SHA256 f480763451083d2f7be8fc23d38e02952ccc383b4cc65e103a9901a0907ce50d
diff --git a/net-zope/zope-authentication/metadata.xml b/net-zope/zope-authentication/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-authentication/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild b/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild
new file mode 100644
index 000000000000..fa052e389626
--- /dev/null
+++ b/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-authentication/zope-authentication-3.7.0.ebuild,v 1.1 2009/11/01 05:20:11 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Definition of authentication basics for the Zope Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.authentication"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-browser
+ net-zope/zope-component
+ net-zope/zope-interface
+ net-zope/zope-schema
+ net-zope/zope-security"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"