summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-01-13 10:11:20 +0000
committerTorsten Veller <tove@gentoo.org>2011-01-13 10:11:20 +0000
commitd933c51601fff354103b0aa5a143e934dafab82a (patch)
treecccfce6afda986807ac8406c5dd289a3e9344438 /perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.33.ebuild
parentVersion bump for stable channel release. (diff)
downloadhistorical-d933c51601fff354103b0aa5a143e934dafab82a.tar.gz
historical-d933c51601fff354103b0aa5a143e934dafab82a.tar.bz2
historical-d933c51601fff354103b0aa5a143e934dafab82a.zip
Version bump
Package-Manager: portage-2.2.0_alpha15/cvs/Linux x86_64
Diffstat (limited to 'perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.33.ebuild')
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.33.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.33.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.33.ebuild
new file mode 100644
index 000000000000..2b2475e72c69
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.33.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.33.ebuild,v 1.1 2011/01/13 10:07:24 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.033
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+
+ cat <<-EOF > "${S}/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = ${EPREFIX}/usr/include
+ LIB = ${EPREFIX}/usr/$(get_libdir)
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+}