summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-01-30 22:18:25 +0000
committerJim Ramsay <lack@gentoo.org>2007-01-30 22:18:25 +0000
commit3182e8d42af4358f604d003bfd1c52d2d2fd7891 (patch)
treef8fcd6a7d5ae92c30a2c9fa1545ef5ee1cb2fd07 /rox-extra/memo/memo-2.0-r1.ebuild
parentStable on amd64 (diff)
downloadhistorical-3182e8d42af4358f604d003bfd1c52d2d2fd7891.tar.gz
historical-3182e8d42af4358f604d003bfd1c52d2d2fd7891.tar.bz2
historical-3182e8d42af4358f604d003bfd1c52d2d2fd7891.zip
Added APPCATEGORY so a .desktop file will be installed
Package-Manager: portage-2.1.2-r4
Diffstat (limited to 'rox-extra/memo/memo-2.0-r1.ebuild')
-rw-r--r--rox-extra/memo/memo-2.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/rox-extra/memo/memo-2.0-r1.ebuild b/rox-extra/memo/memo-2.0-r1.ebuild
new file mode 100644
index 000000000000..0224621d3a67
--- /dev/null
+++ b/rox-extra/memo/memo-2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/memo/memo-2.0-r1.ebuild,v 1.1 2007/01/30 22:18:25 lack Exp $
+
+ROX_LIB_VER=1.9.8
+inherit rox
+
+MY_PN="Memo"
+DESCRIPTION="Memo is a simple alarm clock and clock applet for the ROX Desktop."
+HOMEPAGE="http://rox.sourceforge.net/phpwiki/index.php/Memo"
+SRC_URI="mirror://sourceforge/rox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="libnotify"
+
+RDEPEND="libnotify? (
+ || ( >=dev-python/dbus-python-0.71
+ ( >=sys-apps/dbus-0.60 <sys-apps/dbus-0.90 ) )
+ x11-misc/notification-daemon )"
+
+APPNAME=${MY_PN}
+APPCATEGORY="Utility;Clock"
+
+pkg_setup() {
+ if ! has_version dev-python/dbus-python && \
+ ! built_with_use sys-apps/dbus python
+ then
+ einfo "${APPNAME} requires dbus to be built with python support."
+ einfo "Please rebuild dbus with USE=\"python\"."
+ die "python dbus modules missing"
+ fi
+}
+