summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-28 10:27:49 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-28 10:27:49 +0000
commit02e0f257a345c9c46d6d238a1bad6b4f48053891 (patch)
tree6713dccaa19d7a6ff92f9b39dbfe4400d67c9925 /sci-chemistry/raster3d/raster3d-2.9.1.ebuild
parentStable dev-haskell/c2hs on amd64. (diff)
downloadhistorical-02e0f257a345c9c46d6d238a1bad6b4f48053891.tar.gz
historical-02e0f257a345c9c46d6d238a1bad6b4f48053891.tar.bz2
historical-02e0f257a345c9c46d6d238a1bad6b4f48053891.zip
Version BUmp, keyworded for ~*-linux, as-needed aware linking, removed unneded imake DEPEND
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/raster3d/raster3d-2.9.1.ebuild')
-rw-r--r--sci-chemistry/raster3d/raster3d-2.9.1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sci-chemistry/raster3d/raster3d-2.9.1.ebuild b/sci-chemistry/raster3d/raster3d-2.9.1.ebuild
new file mode 100644
index 000000000000..4215eed27c48
--- /dev/null
+++ b/sci-chemistry/raster3d/raster3d-2.9.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/raster3d-2.9.1.ebuild,v 1.1 2010/03/28 10:27:42 jlec Exp $
+
+EAPI="3"
+
+inherit fortran flag-o-matic multilib toolchain-funcs versionator
+
+MY_PN="Raster3D"
+MY_PV=$(replace_version_separator 2 -)
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A set of tools for generating high quality raster images of proteins or other molecules"
+HOMEPAGE="http://www.bmsc.washington.edu/raster3d/raster3d.html"
+SRC_URI="http://www.bmsc.washington.edu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/tiff"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+}
+
+src_compile() {
+ sed -e "s:prefix = /usr/local:prefix = ${EPREFIX}/usr:" \
+ -i Makefile.template || \
+ die "Failed to patch makefile.template"
+
+ if [[ ${FORTRANC} == gfortran ]]; then
+ append-cflags -Dgfortran
+ fi
+
+ append-fflags -ffixed-line-length-132
+
+ for target in linux-gfortran all; do
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ CC="$(tc-getCC)"\
+ FC="${FORTRANC}" \
+ INCDIRS="-I${EPREFIX}"/usr/include \
+ LIBDIRS="-L${EPREFIX}"/usr/$(get_libdir) \
+ ${target} || die
+ done
+}
+
+src_install() {
+ emake prefix="${ED}"/usr \
+ bindir="${ED}"/usr/bin \
+ datadir="${ED}"/usr/share/Raster3D/materials \
+ mandir="${ED}"/usr/share/man/man1 \
+ htmldir="${ED}"/usr/share/Raster3D/html \
+ examdir="${ED}"/usr/share/Raster3D/examples \
+ install || die "Failed to install application."
+
+ dodir /etc/env.d
+ echo -e "R3D_LIB=${EPREFIX}/usr/share/${NAME}/materials" > \
+ "${D}"/etc/env.d/10raster3d || \
+ die "Failed to install env file."
+}
+
+pkg_postinst() {
+ elog "Add following line:"
+ elog "<delegate decode=\"r3d\" command='\"render\" < \"%i\" > \"%o\"' />"
+ elog "to ${EPREFIX}/usr/$(get_libdir)/ImageMagick-6.5.8/config/delegates.xml"
+ elog "to make imagemagick use raster3d for .r3d files"
+}