summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-10-01 17:33:55 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-10-01 17:33:55 +0000
commit6b3a36326c3e0de89096a5d7be78674ed21a20e4 (patch)
tree2e2c11f06e7aa7731ad0a6a5ac121188994a8c50 /sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
parentMarked Stable on amd64. (diff)
downloadhistorical-6b3a36326c3e0de89096a5d7be78674ed21a20e4.tar.gz
historical-6b3a36326c3e0de89096a5d7be78674ed21a20e4.tar.bz2
historical-6b3a36326c3e0de89096a5d7be78674ed21a20e4.zip
Removing deprecated "gtk2" USE flag (bug #106560).
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild')
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..77dbefbfdfcf
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild,v 1.1 2005/10/01 17:33:55 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="gerbv - The gEDA Gerber Viewer"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+HOMEPAGE="http://www.geda.seul.org"
+
+IUSE="doc png xinerama"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=x11-libs/gtk+-2*
+ png? ( media-libs/libpng
+ media-libs/gdk-pixbuf )
+ virtual/x11"
+
+src_compile() {
+ local confOptions
+
+ confOptions='--enable-gtk2'
+ use xinerama && epatch ${FILESDIR}/${PN}-1.0.0-Xinerama.patch
+ use png || confOptions="$confOptions --disable-exportpng"
+
+ econf $confOptions || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ if use doc; then
+ cd doc
+ dodoc sources.txt
+ use png && dodoc PNG-print/PNGPrintMiniHowto.txt
+ docinto eagle
+ dodoc eagle/eagle2exc*
+ fi
+}