summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-07-03 08:07:37 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-07-03 08:07:37 +0000
commitb659ab060cc3cfc3a7adadfa43e8774ea434f6e0 (patch)
treea746e2edc87d618f0851b19a3a460ed30cce625f /sci-libs/acml
parentAdd all the new blas/cblas/lapack stuff to the eselect 1.0.3 mask. (diff)
downloadhistorical-b659ab060cc3cfc3a7adadfa43e8774ea434f6e0.tar.gz
historical-b659ab060cc3cfc3a7adadfa43e8774ea434f6e0.tar.bz2
historical-b659ab060cc3cfc3a7adadfa43e8774ea434f6e0.zip
Bumps to switch to new eselect modules.
Package-Manager: portage-2.1.1_pre1-r5
Diffstat (limited to 'sci-libs/acml')
-rw-r--r--sci-libs/acml/ChangeLog8
-rw-r--r--sci-libs/acml/acml-3.1.0-r1.ebuild89
-rw-r--r--sci-libs/acml/files/digest-acml-3.1.0-r16
3 files changed, 102 insertions, 1 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index 851c139c6ce0..610648c0e92c 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/acml
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.9 2006/05/15 15:41:59 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.10 2006/07/03 08:06:59 spyderous Exp $
+
+*acml-3.1.0-r1 (03 Jul 2006)
+
+ 03 Jul 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +acml-3.1.0-r1.ebuild:
+ Bumps to switch to new eselect modules.
15 May 2006; Donnie Berkholz <spyderous@gentoo.org>; acml-2.5.0.ebuild:
Update homepage to match the others. Some programs cache the first one they
diff --git a/sci-libs/acml/acml-3.1.0-r1.ebuild b/sci-libs/acml/acml-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..6099ceb484ba
--- /dev/null
+++ b/sci-libs/acml/acml-3.1.0-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.1.0-r1.ebuild,v 1.1 2006/07/03 08:06:59 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="AMD Core Math Library (ACML) for x86 and amd64 CPUs"
+HOMEPAGE="http://developer.amd.com/acml.aspx"
+
+MY_PV=${PV//\./\-}
+S=${WORKDIR}
+
+SRC_URI="amd64? ( acml-${MY_PV}-gnu-64bit.tgz )
+ x86? ( acml-${MY_PV}-gnu-32bit.tgz )"
+RESTRICT="fetch nostrip"
+IUSE="sse sse2"
+LICENSE="ACML"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+RDEPEND="virtual/libc
+ app-admin/eselect-blas
+ app-admin/eselect-cblas
+ app-admin/eselect-lapack"
+PROVIDE="virtual/blas
+ virtual/lapack"
+
+src_unpack() {
+ unpack ${A}
+ if [ "${ARCH}" == "amd64" ] ; then
+ export BITS="64"
+ elif [ "${ARCH}" == "x86" ] ; then
+ export BITS="32"
+ if ! use sse2 ; then
+ use sse \
+ && export SUFFIX="_nosse2" \
+ || export SUFFIX="_nosse"
+ fi
+ fi
+ (DISTDIR="${S}" unpack contents-acml-${MY_PV}-gnu-${BITS}bit.tgz)
+
+ mv Doc doc
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ # Documentation
+ cd ${S}/doc
+ dodoc acml.*
+
+ # Headers
+ mkdir -p ${D}/usr/include/acml/
+ cp ${S}/gnu${BITS}${SUFFIX}/include/* ${D}/usr/include/acml/ \
+ || die "Could not copy header file"
+ cd ${D}/usr/include
+ ln -s acml/acml.h acml.h
+
+ # Libraries
+ mkdir -p ${D}/usr/$(get_libdir)/
+ cp ${S}/gnu${BITS}${SUFFIX}/lib/* ${D}/usr/$(get_libdir)/ \
+ || die "Could not copy library files"
+ unset SUFFIX
+
+ # eselect files
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas acml
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas acml
+ eselect lapack add $(get_libdir) ${FILESDIR}/eselect.lapack acml
+}
+
+pkg_postinst() {
+ if [[ -z "$(eselect blas show)" ]]; then
+ eselect blas set acml
+ fi
+ if [[ -z "$(eselect cblas show)" ]]; then
+ eselect cblas set acml
+ fi
+ if [[ -z "$(eselect lapack show)" ]]; then
+ eselect lapack set acml
+ fi
+
+ einfo "To use ACML's BLAS features, you have to issue (as root):"
+ einfo "\n\teselect blas set acml"
+ einfo "To use ACML's CBLAS features, you have to issue (as root):"
+ einfo "\n\teselect cblas set acml"
+ einfo "To use ACML's LAPACK features, you have to issue (as root):"
+ einfo "\n\teselect lapack set acml"
+}
diff --git a/sci-libs/acml/files/digest-acml-3.1.0-r1 b/sci-libs/acml/files/digest-acml-3.1.0-r1
new file mode 100644
index 000000000000..39d53cbafbbd
--- /dev/null
+++ b/sci-libs/acml/files/digest-acml-3.1.0-r1
@@ -0,0 +1,6 @@
+MD5 fe959ed7661a2b275d92a7e83c7e2b3f acml-3-1-0-gnu-32bit.tgz 24132771
+RMD160 45530e58db9cc6ff31721cca1f440a852ca6a2a9 acml-3-1-0-gnu-32bit.tgz 24132771
+SHA256 32581925aad8df6449453cc62eeaa28a07b6c081b625a8a77e985859466e05de acml-3-1-0-gnu-32bit.tgz 24132771
+MD5 15e933002e5c6c147c15194b5f619093 acml-3-1-0-gnu-64bit.tgz 10052069
+RMD160 6b32df6645068299e3905b5758c16dc1f21960e3 acml-3-1-0-gnu-64bit.tgz 10052069
+SHA256 0d0002310297d03efff198bcc3204b5f690e9387f959d8bd8b78a0e4ca0f2f14 acml-3-1-0-gnu-64bit.tgz 10052069