summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-09-07 10:56:35 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-09-07 10:56:35 +0000
commit26f5092f28df23f2162fc6f281fa776c6bb365b5 (patch)
treee2d2e3623215dd56cb3a99e1f5ad33249c677e78 /sci-libs/indilib/files
parentversion bump (diff)
downloadhistorical-26f5092f28df23f2162fc6f281fa776c6bb365b5.tar.gz
historical-26f5092f28df23f2162fc6f281fa776c6bb365b5.tar.bz2
historical-26f5092f28df23f2162fc6f281fa776c6bb365b5.zip
Version bump. Needed for kstars.
Package-Manager: portage-2.2_rc38/cvs/Linux i686
Diffstat (limited to 'sci-libs/indilib/files')
-rw-r--r--sci-libs/indilib/files/0.6-fix_symlink.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/indilib/files/0.6-fix_symlink.patch b/sci-libs/indilib/files/0.6-fix_symlink.patch
new file mode 100644
index 000000000000..cf447c029da1
--- /dev/null
+++ b/sci-libs/indilib/files/0.6-fix_symlink.patch
@@ -0,0 +1,39 @@
+diff -urN libindi0-0.6.old/CMakeLists.txt libindi0-0.6/CMakeLists.txt
+--- libindi0-0.6.old/CMakeLists.txt 2008-11-18 10:45:06.000000000 +0100
++++ libindi0-0.6/CMakeLists.txt 2009-09-07 12:49:21.000000000 +0200
+@@ -146,7 +146,7 @@
+ ${CMAKE_SOURCE_DIR}/drivers/telescope/lx200gps.cpp
+ ${CMAKE_SOURCE_DIR}/drivers/telescope/lx200generic.cpp
+ ${CMAKE_SOURCE_DIR}/drivers/telescope/lx200classic.cpp
+- ${CMAKE_SOURCE_DIR}/drivers/telescope/lx200apdriver.c
++ ${CMAKE_SOURCE_DIR}/drivers/telescope/lx200apdriver.c
+ ${CMAKE_SOURCE_DIR}/drivers/telescope/lx200ap.cpp )
+
+ add_executable(indi_lx200generic ${lx200generic_SRCS} ${liblilxml_SRCS} ${libindicom_SRCS})
+@@ -159,14 +159,11 @@
+
+ install(TARGETS indi_lx200generic RUNTIME DESTINATION bin )
+
+-file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_lx200generic_symlink.cmake
+-"exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic ${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200classic)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic ${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200autostar)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic ${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200_16)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic ${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200gps)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic ${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200ap)\n
+-")
+-set_target_properties(indi_lx200generic PROPERTIES POST_INSTALL_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/make_lx200generic_symlink.cmake)
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200classic\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}//${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200autostar\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}//${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200_16\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}//${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200gps\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}//${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200ap\" )" )
+ #################################################################################
+
+ ########### Celestron GPS ############
+@@ -521,4 +518,4 @@
+
+ install( FILES indiapi.h indidevapi.h base64.h eventloop.h ${CMAKE_SOURCE_DIR}/libs/lilxml.h
+ ${CMAKE_SOURCE_DIR}/libs/indicom.h DESTINATION ${INCLUDE_INSTALL_DIR}/libindi COMPONENT Devel)
+-
+\ Chybí znak konce řádku na konci souboru
++