summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-22 22:07:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-22 22:07:15 +0000
commita8a1d77240740d82191db03086d9841ce9e672b5 (patch)
tree79cb66a88a25df4242c4ba69e4fb8f3af3610b0b /sci-mathematics/glpk
parentVersion bump, with experimental odbc support and some ebuild cleanups (diff)
downloadhistorical-a8a1d77240740d82191db03086d9841ce9e672b5.tar.gz
historical-a8a1d77240740d82191db03086d9841ce9e672b5.tar.bz2
historical-a8a1d77240740d82191db03086d9841ce9e672b5.zip
Version bump and ebuild cleanup
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/ChangeLog8
-rw-r--r--sci-mathematics/glpk/glpk-4.24.ebuild41
-rw-r--r--sci-mathematics/glpk/glpk-4.29.ebuild (renamed from sci-mathematics/glpk/glpk-4.27.ebuild)30
3 files changed, 24 insertions, 55 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index b89ba998c492..e4b96ace3105 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.23 2008/05/06 19:31:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.24 2008/07/22 22:07:15 bicatali Exp $
+
+*glpk-4.29 (22 Jul 2008)
+
+ 22 Jul 2008; SĂ©bastien Fabbro <bicatali@gentoo.org> -glpk-4.24.ebuild,
+ -glpk-4.27.ebuild, +glpk-4.29.ebuild:
+ Version bump and ebuild cleanup
06 May 2008; Brent Baude <ranger@gentoo.org> glpk-4.28.ebuild:
Marking glpk-4.28 ~ppc64 for bug 219454
diff --git a/sci-mathematics/glpk/glpk-4.24.ebuild b/sci-mathematics/glpk/glpk-4.24.ebuild
deleted file mode 100644
index 43b8bab52807..000000000000
--- a/sci-mathematics/glpk/glpk-4.24.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.24.ebuild,v 1.1 2007/12/04 11:34:42 bicatali Exp $
-
-DESCRIPTION="GNU Linear Programming Kit"
-LICENSE="GPL-2"
-HOMEPAGE="http://www.gnu.org/software/glpk/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-SLOT="0"
-IUSE="doc"
-KEYWORDS="~x86 ~amd64 ~ppc"
-
-DEPEND=">=sys-devel/gcc-3.2
- virtual/libc
- doc? ( virtual/ghostscript )"
-RDEPEND="virtual/libc"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # INSTALL include some usage docs
- dodoc AUTHORS ChangeLog INSTALL NEWS README || \
- die "failed to install docs"
-
- # 385Kb
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.{c,mod,lp,mps,dat} || \
- die "failed to install examples"
-
- # manual/ is 2.5Mb in size
- if use doc; then
- cd "${S}"/doc
- dvipdf refman.dvi
- dvipdf lang.dvi
- insinto /usr/share/doc/${PF}/manual
- doins *.pdf || die "failed to install manual files"
- docinto manual
- dodoc *.txt || die "failed to install manual txt"
- fi
-}
diff --git a/sci-mathematics/glpk/glpk-4.27.ebuild b/sci-mathematics/glpk/glpk-4.29.ebuild
index 8093f832f2d5..441eeea51e41 100644
--- a/sci-mathematics/glpk/glpk-4.27.ebuild
+++ b/sci-mathematics/glpk/glpk-4.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.27.ebuild,v 1.3 2008/03/26 14:03:08 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.29.ebuild,v 1.1 2008/07/22 22:07:15 bicatali Exp $
DESCRIPTION="GNU Linear Programming Kit"
LICENSE="GPL-3"
@@ -8,19 +8,24 @@ HOMEPAGE="http://www.gnu.org/software/glpk/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
SLOT="0"
-IUSE="doc gmp iodbc mysql"
-KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc examples gmp iodbc mysql"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
DEPEND="iodbc? ( dev-db/libiodbc )
gmp? ( dev-libs/gmp )
mysql? ( virtual/mysql )"
src_compile() {
+ local myconf="--disable-dl"
+ if use mysql || use iodbc; then
+ myconf="--enable-dl"
+ fi
econf \
- $(use_enable gmp) \
- $(use_enable iodbc) \
+ --with-zlib \
+ $(use_with gmp) \
+ $(use_enable iodbc odbc) \
$(use_enable mysql) \
- || die "econf failed"
+ ${myconf} || die "econf failed"
emake || die "emake failed"
}
@@ -31,15 +36,14 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README || \
die "failed to install docs"
- # 380Kb
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.{c,mod,lp,mps,dat} || \
- die "failed to install examples"
-
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ emake distclean
+ doins -r examples || die "failed to install examples"
+ fi
if use doc; then
cd "${S}"/doc
- dodoc *.ps *.txt || die "failed to install manual files"
- insinto /usr/share/doc/${PF}
doins memo/gomory.djvu || die "failed to instal memo"
+ dodoc *.ps *.txt || die "failed to install manual files"
fi
}