summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-12-28 18:03:11 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-12-28 18:03:11 +0000
commitbe831a859a48ee6155940ef5b14dae369e97082d (patch)
tree8d4402b67309a130f512302347af139c7e488dc3 /sci-mathematics
parentMarked ppc stable. (diff)
downloadhistorical-be831a859a48ee6155940ef5b14dae369e97082d.tar.gz
historical-be831a859a48ee6155940ef5b14dae369e97082d.tar.bz2
historical-be831a859a48ee6155940ef5b14dae369e97082d.zip
do NOT use awk in global scope. Use bash expressions or versionator.eclass. I have switched to versionator.eclass for simplicity here.
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mupad/ChangeLog7
-rw-r--r--sci-mathematics/mupad/Manifest16
-rw-r--r--sci-mathematics/mupad/mupad-2.5.2-r1.ebuild6
-rw-r--r--sci-mathematics/mupad/mupad-2.5.2-r2.ebuild6
4 files changed, 17 insertions, 18 deletions
diff --git a/sci-mathematics/mupad/ChangeLog b/sci-mathematics/mupad/ChangeLog
index b721876907b5..0312d8f68983 100644
--- a/sci-mathematics/mupad/ChangeLog
+++ b/sci-mathematics/mupad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/mupad
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/ChangeLog,v 1.1 2004/12/28 14:43:46 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/ChangeLog,v 1.2 2004/12/28 18:03:11 seemant Exp $
+
+ 28 Dec 2004; Seemant Kulleen <seemant@gentoo.org> mupad-2.5.2-r1.ebuild,
+ mupad-2.5.2-r2.ebuild:
+ do NOT use awk in global scope. Use bash expressions or versionator.eclass.
+ I have switched to versionator.eclass for simplicity here.
*mupad-2.5.2-r2 (28 Dec 2004)
diff --git a/sci-mathematics/mupad/Manifest b/sci-mathematics/mupad/Manifest
index 69276bd60293..b5a27e06c994 100644
--- a/sci-mathematics/mupad/Manifest
+++ b/sci-mathematics/mupad/Manifest
@@ -1,16 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 bfbf21f11e7e581736fd8d152c6309f2 ChangeLog 1714
+MD5 570a7ec307782d0d3f134bb6c8cda7e8 mupad-2.5.2-r1.ebuild 3163
+MD5 e119e4121a084bb4ac4234dacd07f8e2 ChangeLog 2163
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 5cdd01347d11b830437f4ca6a2fc86a8 mupad-2.5.2-r1.ebuild 3136
-MD5 e4e82a795b224edc36775c33d6ece1a3 mupad-2.5.2-r2.ebuild 3376
+MD5 a40ac6d34848c4d00a0306e0d6bf60c1 mupad-2.5.2-r2.ebuild 3405
MD5 4e05b1eb3ba3380509b9085086cad7ef files/digest-mupad-2.5.2-r1 249
MD5 4e05b1eb3ba3380509b9085086cad7ef files/digest-mupad-2.5.2-r2 249
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBXsT0I1lqEGTUzyQRAke5AJ9AFBesFpYk3TIDvnx3Lo6bAxRJJgCgzf9a
-ARzhnthS24d0tFTwJM6dkSo=
-=h7a5
------END PGP SIGNATURE-----
diff --git a/sci-mathematics/mupad/mupad-2.5.2-r1.ebuild b/sci-mathematics/mupad/mupad-2.5.2-r1.ebuild
index 96957a98ac37..1f97bfbd1137 100644
--- a/sci-mathematics/mupad/mupad-2.5.2-r1.ebuild
+++ b/sci-mathematics/mupad/mupad-2.5.2-r1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/mupad-2.5.2-r1.ebuild,v 1.1 2004/12/28 14:43:46 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/mupad-2.5.2-r1.ebuild,v 1.2 2004/12/28 18:03:11 seemant Exp $
-VER=`echo $PV|awk -F. '{ print $1$2$3 }'`
+inherit versionator
+
+VER=$(replace_all_version_separators '')
URLPATH="ftp://ftp.mupad.de/MuPAD/distrib/unix/"
INSTDIR="/usr/lib/mupad"
INSTBINDIR="${INSTDIR}/share/bin"
diff --git a/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild b/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild
index 191074844ffb..8f2dff2098d6 100644
--- a/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild
+++ b/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild,v 1.1 2004/12/28 14:43:46 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild,v 1.2 2004/12/28 18:03:11 seemant Exp $
-VER=`echo $PV|awk -F. '{ print $1$2$3 }'`
+inherit versionator
+
+VER=$(replace_all_version_separators '')
URLPATH="ftp://ftp.mupad.de/MuPAD/distrib/unix/"
INSTDIR="/usr/lib/mupad"
INSTBINDIR="${INSTDIR}/share/bin"