summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:30:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:30:02 +0000
commit8ec048966e11c2a16f47d0d184d6083f685dac21 (patch)
tree87f468f44cc3bc78ed51765a51d47d1141e1f20f /sci-misc
parentversion bump (diff)
downloadhistorical-8ec048966e11c2a16f47d0d184d6083f685dac21.tar.gz
historical-8ec048966e11c2a16f47d0d184d6083f685dac21.tar.bz2
historical-8ec048966e11c2a16f47d0d184d6083f685dac21.zip
Version bump
Package-Manager: portage-2.2_rc58/cvs/Linux x86_64
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/nco/ChangeLog10
-rw-r--r--sci-misc/nco/metadata.xml14
-rw-r--r--sci-misc/nco/nco-3.9.9.ebuild72
-rw-r--r--sci-misc/ncview/ChangeLog9
-rw-r--r--sci-misc/ncview/ncview-1.93g.ebuild50
5 files changed, 144 insertions, 11 deletions
diff --git a/sci-misc/nco/ChangeLog b/sci-misc/nco/ChangeLog
index 9340dbb744ed..4a1a25f94875 100644
--- a/sci-misc/nco/ChangeLog
+++ b/sci-misc/nco/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/nco
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.14 2009/03/24 19:16:47 betelgeuse Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.15 2009/12/12 18:25:32 bicatali Exp $
+
+*nco-3.9.9 (12 Dec 2009)
+
+ 12 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org> +nco-3.9.9.ebuild,
+ metadata.xml:
+ Version bump
24 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> nco-3.9.4.ebuild:
Slot dep for antlr.
diff --git a/sci-misc/nco/metadata.xml b/sci-misc/nco/metadata.xml
index ac146995f919..5dd3778e42f1 100644
--- a/sci-misc/nco/metadata.xml
+++ b/sci-misc/nco/metadata.xml
@@ -3,13 +3,13 @@
<pkgmetadata>
<herd>sci</herd>
<longdescription lang="en">
-Command-line operators to analyze netCDF files
-NetCDF Operator is a suite of programs known as operators. The
-operators are stand-alone, command-line programs executable in a POSIX
-shell. Operators take one or more netCDF files as input, perform an
-operation (e.g., averaging or hyperslabbing), and produce a netCDF
-output file. NCO was originally designed to manipulate and analyze
-climate data, though it works on any netCDF format datasets.
+ Command-line operators to analyze netCDF files
+ NetCDF Operator is a suite of programs known as operators. The
+ operators are stand-alone, command-line programs executable in a POSIX
+ shell. Operators take one or more netCDF files as input, perform an
+ operation (e.g., averaging or hyperslabbing), and produce a netCDF
+ output file. NCO was originally designed to manipulate and analyze
+ climate data, though it works on any netCDF format datasets.
</longdescription>
<use>
<flag name='ncap2'>Build next generation netcdf arithmetic processor
diff --git a/sci-misc/nco/nco-3.9.9.ebuild b/sci-misc/nco/nco-3.9.9.ebuild
new file mode 100644
index 000000000000..b09c7e9df93b
--- /dev/null
+++ b/sci-misc/nco/nco-3.9.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/nco-3.9.9.ebuild,v 1.1 2009/12/12 18:25:32 bicatali Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+DESCRIPTION="Command line utilities for operating on netCDF files"
+SRC_URI="http://dust.ess.uci.edu/nco/src/${P}.tar.gz"
+HOMEPAGE="http://nco.sourceforge.net/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+IUSE="doc mpi ncap2 udunits"
+
+RDEPEND="sci-libs/netcdf
+ mpi? ( virtual/mpi )
+ dap? ( sci-libs/netcdf )
+ udunits? ( >=sci-libs/udunits-2 )"
+
+DEPEND="${RDEPEND}
+ ncap2? ( !mpi? ( dev-java/antlr:0 ) )
+ doc? ( virtual/latex-base )"
+
+pkg_setup() {
+ if use mpi && use ncap2; then
+ elog
+ elog "mpi and ncap2 are still incompatible flags"
+ elog "nco configure will automatically disables ncap2"
+ elog
+ fi
+}
+
+src_configure() {
+ local myconf
+ if has_version ">=sci-libs/netcdf-4" && built_with_use sci-libs/netcdf hdf5; then
+ append-cppflags -DHAVE_NETCDF4_H
+ myconf="--enable-netcdf4"
+ else
+ myconf="--disable-netcdf4"
+ fi
+ econf \
+ ${myconf} \
+ --disable-udunits \
+ $(use_enable ncap2) \
+ $(use_enable udunits udunits2) \
+ $(use_enable mpi)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ cd doc
+ emake clean info
+ if use doc; then
+ VARTEXFONTS="${T}/fonts" emake html pdf || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd doc
+ dodoc ANNOUNCE ChangeLog MANIFEST NEWS README TAG TODO VERSION *.txt \
+ || die "dodoc failed"
+ doinfo *.info* || die "doinfo failed"
+ if use doc; then
+ dohtml nco.html/* || die "dohtml failed"
+ insinto /usr/share/doc/${PF}
+ doins nco.pdf || die "pdf install failed"
+ fi
+}
diff --git a/sci-misc/ncview/ChangeLog b/sci-misc/ncview/ChangeLog
index 917f4e06299b..52304ceaa846 100644
--- a/sci-misc/ncview/ChangeLog
+++ b/sci-misc/ncview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/ncview
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ChangeLog,v 1.14 2008/08/06 18:29:54 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ChangeLog,v 1.15 2009/12/12 18:30:02 bicatali Exp $
+
+*ncview-1.93g (12 Dec 2009)
+
+ 12 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org> +ncview-1.93g.ebuild:
+ Version bump
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-misc/ncview/ncview-1.93g.ebuild b/sci-misc/ncview/ncview-1.93g.ebuild
new file mode 100644
index 000000000000..b1541883b928
--- /dev/null
+++ b/sci-misc/ncview/ncview-1.93g.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ncview-1.93g.ebuild,v 1.1 2009/12/12 18:30:02 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="X-based viewer for netCDF files"
+SRC_URI="ftp://cirrus.ucsd.edu/pub/ncview/${P}.tar.gz"
+HOMEPAGE="http://meteora.ucsd.edu/~pierce/ncview_home_page.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="udunits"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="sci-libs/netcdf
+ media-libs/netpbm
+ x11-libs/libXaw
+ udunits? ( sci-libs/udunits )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # force netpbm (could be a use flag, but worth it?)
+ econf \
+ --x-libraries=/usr/$(get_libdir) \
+ --x-include=/usr/include \
+ --with-libppm \
+ $(use_with udunits)
+}
+
+src_install() {
+ local appdef=/usr/share/X11/app-defaults
+ dodir ${appdef}
+ dodir /usr/share/${PN}
+ # fix when root installs it.
+ sed -i \
+ -e "s:/usr/lib/X11/app-defaults:${D}${appdef}:g" \
+ install-appdef || die "sed failed"
+ emake \
+ DESTDIR="${D}" \
+ BINDIR="${D}/usr/bin" \
+ MANDIR="${D}/usr/share/man/man1" \
+ NCVIEW_LIB_DIR="${D}/usr/share/${PN}" \
+ XAPPLRESDIR="${D}/usr/share/X11/app-defaults" \
+ install || die "emake install failed"
+ insinto /usr/share/${PN}
+ doins *.ncmap nc_overlay* || die "doins failed"
+ dodoc README README_WISH_LIST RELEASE_NOTES || die
+}