summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2005-10-31 08:26:30 +0000
committerPeter Bienstman <pbienst@gentoo.org>2005-10-31 08:26:30 +0000
commitc6918a63f5cee41ebaf8b402005be0058b4c7efe (patch)
treec67c2140c9ba2d080f50bd05082a5d414123360b /sci-misc
parent~ia64 keyword. (diff)
downloadhistorical-c6918a63f5cee41ebaf8b402005be0058b4c7efe.tar.gz
historical-c6918a63f5cee41ebaf8b402005be0058b4c7efe.tar.bz2
historical-c6918a63f5cee41ebaf8b402005be0058b4c7efe.zip
Use fortran eclass.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/camfr/ChangeLog5
-rw-r--r--sci-misc/camfr/Manifest4
-rw-r--r--sci-misc/camfr/camfr-1.2.ebuild12
3 files changed, 9 insertions, 12 deletions
diff --git a/sci-misc/camfr/ChangeLog b/sci-misc/camfr/ChangeLog
index 7bdb61514141..4653b9d0f776 100644
--- a/sci-misc/camfr/ChangeLog
+++ b/sci-misc/camfr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-misc/camfr
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/ChangeLog,v 1.1 2005/04/05 07:52:12 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/ChangeLog,v 1.2 2005/10/31 08:26:30 pbienst Exp $
+
+ 31 Oct 2005; Peter Bienstman <pbienst@gentoo.org> camfr-1.2.ebuild:
+ Use fortran eclass.
05 Apr 2005; Peter Bienstman <pbienst@gentoo.org> :
Initial import. Closes bug 36560.
diff --git a/sci-misc/camfr/Manifest b/sci-misc/camfr/Manifest
index 5a2db343fbad..41cc34473057 100644
--- a/sci-misc/camfr/Manifest
+++ b/sci-misc/camfr/Manifest
@@ -1,5 +1,5 @@
-MD5 e444a55e7213fa934499628af573f0c3 camfr-1.2.ebuild 1721
-MD5 af9cc9adb236ecbe37bdf5cf7b4471ee ChangeLog 293
+MD5 9e7bab8dc8ecb2ab616f8e0f47227c0a camfr-1.2.ebuild 1519
+MD5 a9c52ba3af5c65b11df7c519b8c2f157 ChangeLog 386
MD5 b29bc1bc900b3946fa0120f24f1061df metadata.xml 254
MD5 85926d5ac680e6e8b6c0271a4527f030 files/SConstruct 611
MD5 d2774ba5f369e9f1f58d5bc1f5d0e3ad files/camfr_wrap.cpp 33757
diff --git a/sci-misc/camfr/camfr-1.2.ebuild b/sci-misc/camfr/camfr-1.2.ebuild
index 51ede579e9fc..82adbff59939 100644
--- a/sci-misc/camfr/camfr-1.2.ebuild
+++ b/sci-misc/camfr/camfr-1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/camfr-1.2.ebuild,v 1.1 2005/04/05 07:52:12 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/camfr-1.2.ebuild,v 1.2 2005/10/31 08:26:30 pbienst Exp $
-inherit eutils distutils
+inherit eutils distutils fortran
S=${WORKDIR}/camfr_${PV}
IUSE="ifc"
@@ -22,15 +22,9 @@ DEPEND="dev-lang/python
virtual/tetex
app-text/ghostscript
>=app-text/texi2html-1.64"
+FORTAN="g77"
src_unpack() {
- use ifc || if [ -z `which g77` ]; then
- #if ifc is defined then the dep was already checked
- eerror "No fortran compiler found on the system!"
- eerror "Please add fortran to your USE flags and reemerge gcc!"
- die
- fi
-
python -c "import ImageTk" 2>/dev/null
if [ $? -ne 0 ]; then
eerror "Python and imaging don't have Tk support enabled."