summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-06 14:23:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-06 14:23:19 +0000
commitc679729b2154e411bee680eb47843d014181e8bf (patch)
tree0baf7d6e5272110a0685420488b9ee737610e64f /sci-physics/harminv/harminv-1.3.1.ebuild
parentsparc stable (diff)
downloadhistorical-c679729b2154e411bee680eb47843d014181e8bf.tar.gz
historical-c679729b2154e411bee680eb47843d014181e8bf.tar.bz2
historical-c679729b2154e411bee680eb47843d014181e8bf.zip
Initial import. Ebuild first submitted by Ben Schwartz, see bug #170989
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'sci-physics/harminv/harminv-1.3.1.ebuild')
-rw-r--r--sci-physics/harminv/harminv-1.3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-physics/harminv/harminv-1.3.1.ebuild b/sci-physics/harminv/harminv-1.3.1.ebuild
new file mode 100644
index 000000000000..9612704ec195
--- /dev/null
+++ b/sci-physics/harminv/harminv-1.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/harminv/harminv-1.3.1.ebuild,v 1.1 2008/02/06 14:23:18 bicatali Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Extraction of complex frequencies and amplitudes from time series"
+HOMEPAGE="http://ab-initio.mit.edu/harminv/"
+SRC_URI="http://ab-initio.mit.edu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.ac.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README || die "dodoc failed"
+}