summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-09-07 22:10:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-09-07 22:10:27 +0000
commit24627b2b76f358017e7b54e5c5230663d081f663 (patch)
treed7288112d8acaf202d6231193248b325b0e8ba2b /sci-physics/lhapdf
parentDon't run encoder tests without use encode, bug #212315 (diff)
downloadhistorical-24627b2b76f358017e7b54e5c5230663d081f663.tar.gz
historical-24627b2b76f358017e7b54e5c5230663d081f663.tar.bz2
historical-24627b2b76f358017e7b54e5c5230663d081f663.zip
Initial import, inspired from Benjamin Bannier's work (bug #236719)
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64
Diffstat (limited to 'sci-physics/lhapdf')
-rw-r--r--sci-physics/lhapdf/ChangeLog10
-rw-r--r--sci-physics/lhapdf/Manifest14
-rw-r--r--sci-physics/lhapdf/lhapdf-5.5.0.ebuild65
-rw-r--r--sci-physics/lhapdf/metadata.xml18
4 files changed, 107 insertions, 0 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
new file mode 100644
index 000000000000..91e0b434fcc8
--- /dev/null
+++ b/sci-physics/lhapdf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/lhapdf
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.1 2008/09/07 22:10:27 bicatali Exp $
+
+*lhapdf-5.5.0 (07 Sep 2008)
+
+ 07 Sep 2008; SĂ©bastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +lhapdf-5.5.0.ebuild:
+ Initial import, inspired from Benjamin Bannier's work (bug #236719)
+
diff --git a/sci-physics/lhapdf/Manifest b/sci-physics/lhapdf/Manifest
new file mode 100644
index 000000000000..e456f60037d5
--- /dev/null
+++ b/sci-physics/lhapdf/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST lhapdf-5.5.0.tar.gz 50539943 RMD160 f62af6f9a7ccd3494f26825d63b6afc6198b7b69 SHA1 9c0a60429b90d1bf4aab9b25134643a72a90974d SHA256 40a941477cfa225acbb1dba0ef79cdc051331ecae0c56996a53e8f45459cb405
+EBUILD lhapdf-5.5.0.ebuild 1691 RMD160 28e8ba8eeed3d5b5449dd9ba508f7033d351af16 SHA1 f7befd39a43b5ed84b07c0fd2fdf342f27fab72c SHA256 2567ce31bb7c6fbcc71ffefb806bbe9676b269e21f448d77d891d138eddc948a
+MISC ChangeLog 405 RMD160 54765e65ea27158842e6dc729260327013f4c5ae SHA1 fac7338c9ad46c6898f09746ed2b29b99c0f95c7 SHA256 da342a4fcd42ca1241d809d4d74dea11669246c9ea07032866213c9933d9f70b
+MISC metadata.xml 901 RMD160 f8324b5d4ab59033b1fe1e9a53148c22e75d25ab SHA1 031b1ad488f61fbf0d4da63ea73a56f4c945c4c8 SHA256 3f5f5746a95fb877dabeb4d7afc0bbd1051797f5818c94b86a8e032845364365
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkjEUV4ACgkQ1ycZbhPLE2B0KQCfem8X4qZAC8OPBsMjw4uF9vsP
+e70AoKi7AOWxNNaGDJFe6ZduiA0ht3/9
+=L1Cl
+-----END PGP SIGNATURE-----
diff --git a/sci-physics/lhapdf/lhapdf-5.5.0.ebuild b/sci-physics/lhapdf/lhapdf-5.5.0.ebuild
new file mode 100644
index 000000000000..55510ca6971b
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-5.5.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.5.0.ebuild,v 1.1 2008/09/07 22:10:27 bicatali Exp $
+
+inherit eutils fortran
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://projects.hepforge.org/lhapdf/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples python"
+
+DEPEND="doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )"
+RDEPEND=""
+
+pkg_setup() {
+ local err
+ if use python && ! built_with_use dev-lang/swig python; then
+ eerror "You need USE=python in dev-lang/swig for python support."
+ err="${err} python"
+ fi
+ # this is needed for formulas even with html output only
+ if use doc && ! built_with_use app-doc/doxygen latex; then
+ eerror "You need USE=latex in app-doc/doxygen for docs."
+ err="${err} latex"
+ fi
+
+ [ -z "${err}" ] || die "Unsatisfied dependencies -- needs manual fix"
+
+ FORTRAN="gfortran ifc"
+ fortran_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # do not create extra latex docs
+ sed -i \
+ -e 's/GENERATE_LATEX.*=YES/GENERATE_LATEX = NO/g' \
+ ccwrap/Doxyfile || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable python pyext) \
+ $(use_enable doc doxygen) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO AUTHORS ChangeLog
+
+ use doc && mv "${D}"/usr/share/${PN}/doc/html "${D}"/usr/share/doc/${PF}
+ rm -rf "${D}"/usr/share/${PN}/doc
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+}
diff --git a/sci-physics/lhapdf/metadata.xml b/sci-physics/lhapdf/metadata.xml
new file mode 100644
index 000000000000..0ee0caff5105
--- /dev/null
+++ b/sci-physics/lhapdf/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ Les Houches Parton Density Function (LHAPDF)
+ provides a unified and easy to use interface to modern PDF
+ sets. It is designed to work not only with individual PDF sets but
+ also with the more recent multiple "error" sets. It can be viewed as
+ the successor to PDFLIB, incorporating many of the older sets found in
+ the latter, including pion and photon PDFs. In LHAPDF the computer
+ code and input parameters/grids are separated thus allowing more easy
+ updating and no limit to the expansion possibilities. The code and
+ data sets can be downloaded together or individually as desired. From
+ version 4.1 onwards a configuration script facilitates the
+ installation of LHAPDF.
+</longdescription>
+</pkgmetadata>