summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-09-10 18:31:13 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-09-10 18:31:13 +0000
commit1cddb084c476b2ce64b96b0be3daa53a603435b1 (patch)
tree49360258757a717c61f4333423a3d417184dbf35 /sci-visualization/pythonprop/pythonprop-0.11.ebuild
parent[app-admin/logrotate] Dropped mips and x86-fbsd stable keywords and tune flag... (diff)
downloadhistorical-1cddb084c476b2ce64b96b0be3daa53a603435b1.tar.gz
historical-1cddb084c476b2ce64b96b0be3daa53a603435b1.tar.bz2
historical-1cddb084c476b2ce64b96b0be3daa53a603435b1.zip
Version bump
Package-Manager: portage-2.1.11.14/cvs/Linux x86_64
Diffstat (limited to 'sci-visualization/pythonprop/pythonprop-0.11.ebuild')
-rw-r--r--sci-visualization/pythonprop/pythonprop-0.11.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-visualization/pythonprop/pythonprop-0.11.ebuild b/sci-visualization/pythonprop/pythonprop-0.11.ebuild
new file mode 100644
index 000000000000..022e3e71c5f9
--- /dev/null
+++ b/sci-visualization/pythonprop/pythonprop-0.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pythonprop/pythonprop-0.11.ebuild,v 1.1 2012/09/10 18:31:13 tomjbe Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Scripts to prepare and plot VOACAP propagation predictions"
+HOMEPAGE="http://www.qsl.net/hz1jw/pythonprop"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sci-electronics/voacapl
+ dev-python/matplotlib[gtk]
+ dev-python/basemap"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS TODO || die
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}