summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 17:03:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 17:03:33 +0000
commit2a3a258c1d9d60e8dd613794094768095875dc9a (patch)
tree0cb617a1d0f8ecd36296970a8c731171c9cf8e26 /sci-visualization/pyxplot
parentDelete call to deprecated python_version(). (diff)
downloadhistorical-2a3a258c1d9d60e8dd613794094768095875dc9a.tar.gz
historical-2a3a258c1d9d60e8dd613794094768095875dc9a.tar.bz2
historical-2a3a258c1d9d60e8dd613794094768095875dc9a.zip
Use Python 2. Delete call to deprecated python_version().
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'sci-visualization/pyxplot')
-rw-r--r--sci-visualization/pyxplot/ChangeLog6
-rw-r--r--sci-visualization/pyxplot/Manifest4
-rw-r--r--sci-visualization/pyxplot/pyxplot-0.7.1.ebuild14
3 files changed, 17 insertions, 7 deletions
diff --git a/sci-visualization/pyxplot/ChangeLog b/sci-visualization/pyxplot/ChangeLog
index 783281943d1a..7c3949a1d04c 100644
--- a/sci-visualization/pyxplot/ChangeLog
+++ b/sci-visualization/pyxplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/pyxplot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/ChangeLog,v 1.16 2010/02/04 16:55:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/ChangeLog,v 1.17 2010/06/04 17:03:33 arfrever Exp $
+
+ 04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pyxplot-0.7.1.ebuild:
+ Use Python 2. Delete call to deprecated python_version().
04 Feb 2010; Markos Chandras <hwoarang@gentoo.org> pyxplot-0.7.1.ebuild:
Stable on amd64 wrt bug #270481
diff --git a/sci-visualization/pyxplot/Manifest b/sci-visualization/pyxplot/Manifest
index 42aebdb48e56..1079fa1f3aac 100644
--- a/sci-visualization/pyxplot/Manifest
+++ b/sci-visualization/pyxplot/Manifest
@@ -1,5 +1,5 @@
AUX 0.7.0-dont-build-pyx.patch 907 RMD160 986ab5c9beb99789f73f0ef759768ac7213179b3 SHA1 3f131e22a9469d7b394e7f47c97d459409f74da1 SHA256 72849e7b7a30d82d0c826bc288233f62cfff20755f9444be60c4563501df0bab
DIST pyxplot_0.7.1.tar.gz 2439857 RMD160 f1383bbdb0b92ca0197614e835f6690475e140bf SHA1 ad69725bb6a545acd786a5084a9f29d7728d1ecc SHA256 262b4337c1fdb8e54c11eb76415b814243f6dbab28163fd1e208378d860d2a84
-EBUILD pyxplot-0.7.1.ebuild 1194 RMD160 cdfcd7f5d0a1a765b08a4c6ff14470f3759c9df6 SHA1 4dab4d294d6a0e97daa579dc16abb916ba3928be SHA256 60fcc810a34fc86a667a6829cd94017551d0bb726eab897e554366f5616d49d2
-MISC ChangeLog 2780 RMD160 6bf22cef5a43ccc90bac931d11c9845579369fe3 SHA1 05bcfe550bebe4de8ad42be578280ab06aaa3c5e SHA256 338b0fa35f7d3eade72aa2fe255f4f40e9af151c59d6fe824f652b2ef3fb5c0e
+EBUILD pyxplot-0.7.1.ebuild 1251 RMD160 15dcde6632e90c09dd35052bf6e1857de137667b SHA1 039766369303a646b6083df72761c7661a363083 SHA256 8433a6a128e3a3033b8f2e9a861ee9c34758c587da2869ec15d09632b5acd0b0
+MISC ChangeLog 2938 RMD160 c605ec8c1c7e62ee43bb4c263fd5c43e24421cd1 SHA1 54aa5750961ca84436963b0cd4ad9477c3b09988 SHA256 e07b5e0758e11c7db83f779a1b7d0029b5806d07d45215253d502abea41f1ecd
MISC metadata.xml 463 RMD160 9002790a044085c85a9ef8f94e310a3f0602b667 SHA1 3f2b28ca789f28fdca734821c144549edf23ed26 SHA256 af4c2cc250cdbadddb1c217fb2e1feec6da9f7b7247f84c1cc760de4ed8f67fb
diff --git a/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild b/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
index e927b64d3462..436bf9aecd4f 100644
--- a/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
+++ b/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild,v 1.3 2010/02/04 16:55:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pyxplot/pyxplot-0.7.1.ebuild,v 1.4 2010/06/04 17:03:33 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
-EAPI=2
inherit eutils python
DESCRIPTION="Gnuplot like graphing program publication-quality figures"
@@ -21,11 +23,15 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
- python_version
sed -i \
-e "s:^\(USRDIR=\).*:\1/usr:g" \
- -e "s:^\(SRCDIR=\).*:\1/usr/$(get_libdir)/python${PYVER}/${PN}:g" \
+ -e "s:^\(SRCDIR=\).*:\1$(python_get_sitedir)/${PN}:g" \
-e 's:^\(MANDIR=\).*:\1${USRDIR}/share/man/man1:g' \
-e "s:^\(DOCDIR=\).*:\1\${USRDIR}/share/doc/${PF}:g" \
-e '/install:/,$s:${\(SRC\|BIN\|DOC\|MAN\)DIR:${DESTDIR}/${\1DIR:g' \