summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-05-20 22:55:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-05-20 22:55:06 +0000
commitcb4ab77b6fc49730e320372ea1956a53d8acb5b2 (patch)
tree3d2e9255f8243ca4a24aeb780770ebcb19c88efa /skel.ebuild
parentBump, unstable only (diff)
downloadhistorical-cb4ab77b6fc49730e320372ea1956a53d8acb5b2.tar.gz
historical-cb4ab77b6fc49730e320372ea1956a53d8acb5b2.tar.bz2
historical-cb4ab77b6fc49730e320372ea1956a53d8acb5b2.zip
Spell-checked.
Added note about econf and einstall and || die so people like me stop bringing up this issue.
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/skel.ebuild b/skel.ebuild
index cc0348c63dbb..fcd79582c1ea 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -8,7 +8,7 @@
# doesn't mean you can't add your own comments though.
# The 'Header' on the third line should just be left alone. When your ebuild
-# will be commited to cvs, the details on that line will be automatically
+# will be committed to cvs, the details on that line will be automatically
# generated to contain the correct data.
# Short one-line description of this package.
@@ -49,7 +49,7 @@ SLOT="0"
# stability. Once packages go stable the ~ prefix is removed.
# So, if you've confirmed that your ebuild works on x86 and ppc,
# you'd specify: KEYWORDS="~x86 ~ppc"
-# For packages that are platform-independant (like Java, PHP or Perl
+# For packages that are platform-independent (like Java, PHP or Perl
# applications) specify all keywords.
# DO NOT USE KEYWORDS="*". This is deprecated and only for backward
# compatibility reasons.
@@ -99,6 +99,8 @@ src_compile() {
# portage shortcut to the above ./configure statement:
#
# econf || die
+ # Note that econf will die on failure, but plase use econf || die
+ # for consistency.
# emake (previously known as pmake) is a script that calls the
# standard GNU make with parallel building options for speedier
@@ -130,4 +132,6 @@ src_install() {
# The portage shortcut to the above command is simply:
#
#einstall || die
+ # Note that einstall will die on failure, but please use einstall || die
+ # for consistency.
}