summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-18 23:57:49 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-18 23:57:49 +0000
commit2ed16820af5938414bf315027956df3ab5199a55 (patch)
tree394300459135598f88755e203f152efd9d5147d6 /sys-apps/aboot
parentremoved old quakeforge mask (diff)
downloadhistorical-2ed16820af5938414bf315027956df3ab5199a55.tar.gz
historical-2ed16820af5938414bf315027956df3ab5199a55.tar.bz2
historical-2ed16820af5938414bf315027956df3ab5199a55.zip
lintool fixes per #9258
Diffstat (limited to 'sys-apps/aboot')
-rw-r--r--sys-apps/aboot/aboot-0.9-r1.ebuild54
1 files changed, 23 insertions, 31 deletions
diff --git a/sys-apps/aboot/aboot-0.9-r1.ebuild b/sys-apps/aboot/aboot-0.9-r1.ebuild
index 7ade8d510a70..915506a1e13f 100644
--- a/sys-apps/aboot/aboot-0.9-r1.ebuild
+++ b/sys-apps/aboot/aboot-0.9-r1.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/aboot/aboot-0.9-r1.ebuild,v 1.3 2002/10/18 23:57:49 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Alpha Linux boot loader for srm"
@@ -8,15 +9,12 @@ HOMEPAGE="http://aboot.sourceforge.net/"
KEYWORDS="alpha"
SLOT="0"
-LICENSE="gpl-2"
+LICENSE="GPL-2"
DEPEND="virtual/glibc"
-
-RDEPEND="virtual/glibc"
-
+RDEPEND="${DEPEND}"
src_unpack() {
-
unpack ${A}
mv ${WORKDIR}/aboot-0.9bpre ${WORKDIR}/${P}
@@ -27,12 +25,10 @@ src_unpack() {
}
src_compile() {
-
emake || die
}
src_install() {
-
dodir /{boot,sbin,usr/share/man/man5}
make \
root=${D} \
@@ -46,31 +42,27 @@ src_install() {
dodir /etc
insinto /etc
newins ${FILESDIR}/aboot.conf aboot.conf.example
-
}
pkg_postinst() {
-
- einfo "To make aboot install a new bootloader on your harddisk follow"
- einfo "these steps:"
- einfo ""
- einfo " - edit the file /etc/aboot.conf"
- einfo " - cd /boot"
- einfo " - swriteboot -c2 /dev/sda bootlx"
- einfo " This will install a new bootsector on /dev/sda and aboot will"
- einfo " use the second partition on this device to lookup kernel and "
- einfo " initrd (as described in the aboot.conf file)"
- einfo ""
- einfo "IMPORTANT :"
- einfo ""
- einfo "The partition table of your boot device has to contain "
- einfo "a BSD-DISKLABEL and the first 12 megabytes of your boot device"
- einfo "must not be part of a partition as aboot will write its bootloader"
- einfo "in there and not as with most x86 bootloaders into the "
- einfo "master boot sector. If your partition table does not reflect this"
- einfo "you are going to destroy your installation !"
- einfo "Also note that aboot currently only supports ext2/3 partitions"
- einfo "to boot from."
-
+ einfo "To make aboot install a new bootloader on your harddisk follow"
+ einfo "these steps:"
+ einfo ""
+ einfo " - edit the file /etc/aboot.conf"
+ einfo " - cd /boot"
+ einfo " - swriteboot -c2 /dev/sda bootlx"
+ einfo " This will install a new bootsector on /dev/sda and aboot will"
+ einfo " use the second partition on this device to lookup kernel and "
+ einfo " initrd (as described in the aboot.conf file)"
+ einfo ""
+ einfo "IMPORTANT :"
+ einfo ""
+ einfo "The partition table of your boot device has to contain "
+ einfo "a BSD-DISKLABEL and the first 12 megabytes of your boot device"
+ einfo "must not be part of a partition as aboot will write its bootloader"
+ einfo "in there and not as with most x86 bootloaders into the "
+ einfo "master boot sector. If your partition table does not reflect this"
+ einfo "you are going to destroy your installation !"
+ einfo "Also note that aboot currently only supports ext2/3 partitions"
+ einfo "to boot from."
}
-