summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 13:27:25 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 13:27:25 +0000
commit9f7da337120e84276a5f68f1d2ce85406c18fc55 (patch)
tree6e4485730ceeb2df40751115cf5b0d0776465cf8 /sys-apps/console-tools
parent*** empty log message *** (diff)
downloadhistorical-9f7da337120e84276a5f68f1d2ce85406c18fc55.tar.gz
historical-9f7da337120e84276a5f68f1d2ce85406c18fc55.tar.bz2
historical-9f7da337120e84276a5f68f1d2ce85406c18fc55.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/console-tools')
-rw-r--r--sys-apps/console-tools/console-tools-0.2.3-r2.ebuild39
-rwxr-xr-xsys-apps/console-tools/files/console-tools-0.2.3.patch.gzbin0 -> 4059 bytes
-rw-r--r--sys-apps/console-tools/files/digest-console-tools-0.2.3-r21
3 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/console-tools/console-tools-0.2.3-r2.ebuild b/sys-apps/console-tools/console-tools-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..22083c157956
--- /dev/null
+++ b/sys-apps/console-tools/console-tools-0.2.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.2.3-r2.ebuild,v 1.1 2000/11/26 13:27:25 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Console and font utilities"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/keyboards/${A}"
+HOMEPAGE="http://altern.org/ydirson/en/lct/"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gzip -dc ${FILESDIR}/${PN}-${PV}.patch.gz | patch -p1
+}
+
+src_compile() {
+ try ./configure --prefix=/usr --host=${CHOST}
+ mv Makefile Makefile.orig
+ #building without documentation for now
+ sed -e s/doc// Makefile.orig > Makefile
+ try make all
+}
+
+src_install() {
+ into /usr
+ cd ${S}
+ try make DESTDIR=${D} install
+ strip ${D}/usr/bin/*
+ strip --strip-unneeded ${D}/usr/lib/*.so.0.0.0
+ dodoc BUGS COPYING* CREDITS ChangeLog NEWS README RELEASE TODO
+ gzip -9 ${D}/usr/man/man8/*.8
+ MOPREFIX="console-tools"
+ domo ${S}/po/*.gmo
+}
+
+
+
diff --git a/sys-apps/console-tools/files/console-tools-0.2.3.patch.gz b/sys-apps/console-tools/files/console-tools-0.2.3.patch.gz
new file mode 100755
index 000000000000..ae07ad7dd0db
--- /dev/null
+++ b/sys-apps/console-tools/files/console-tools-0.2.3.patch.gz
Binary files differ
diff --git a/sys-apps/console-tools/files/digest-console-tools-0.2.3-r2 b/sys-apps/console-tools/files/digest-console-tools-0.2.3-r2
new file mode 100644
index 000000000000..7c2347441144
--- /dev/null
+++ b/sys-apps/console-tools/files/digest-console-tools-0.2.3-r2
@@ -0,0 +1 @@
+MD5 983d4586a791b3fdfa0fbeff76aadf43 console-tools-0.2.3.tar.gz