summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2010-06-24 20:46:14 +0000
committerSven Wegener <swegener@gentoo.org>2010-06-24 20:46:14 +0000
commitc83e331c5ba300683423e838a6cb6ca7d9b9faea (patch)
treed344b5d2dec61186f9bed2c1840fab7576dbd52f /sys-apps/dstat/dstat-0.7.2.ebuild
parentstable amd64, bug 325041 (diff)
downloadhistorical-c83e331c5ba300683423e838a6cb6ca7d9b9faea.tar.gz
historical-c83e331c5ba300683423e838a6cb6ca7d9b9faea.tar.bz2
historical-c83e331c5ba300683423e838a6cb6ca7d9b9faea.zip
Version bump, bug #297555.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/dstat/dstat-0.7.2.ebuild')
-rw-r--r--sys-apps/dstat/dstat-0.7.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/dstat/dstat-0.7.2.ebuild b/sys-apps/dstat/dstat-0.7.2.ebuild
new file mode 100644
index 000000000000..fde02ccdbeea
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.7.2.ebuild,v 1.1 2010/06/24 20:46:14 swegener Exp $
+
+EAPI=2
+
+inherit python eutils
+
+DESCRIPTION="Dstat is a versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/python"
+DEPEND=""
+
+src_compile() {
+ true
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+
+ dodoc \
+ AUTHORS ChangeLog README TODO \
+ examples/{mstat,read}.py docs/*.txt \
+ || die "dodoc failed"
+ dohtml docs/*.html || die "dohtml failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/dstat
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/dstat
+}