summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-25 14:29:50 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-25 14:29:50 +0000
commitf9291f80ccd338d384882405260fe1d420bc74eb (patch)
treeb9dd7868892ffe158efd7d969beea2e87682a961 /sys-apps/fileutils
parentAdded alpha to KEYWORDS (diff)
downloadhistorical-f9291f80ccd338d384882405260fe1d420bc74eb.tar.gz
historical-f9291f80ccd338d384882405260fe1d420bc74eb.tar.bz2
historical-f9291f80ccd338d384882405260fe1d420bc74eb.zip
new version
Diffstat (limited to 'sys-apps/fileutils')
-rw-r--r--sys-apps/fileutils/ChangeLog7
-rw-r--r--sys-apps/fileutils/files/digest-fileutils-4.1.111
-rw-r--r--sys-apps/fileutils/files/fileutils-4.1.11-configure.patch11
-rw-r--r--sys-apps/fileutils/fileutils-4.1.11.ebuild67
4 files changed, 85 insertions, 1 deletions
diff --git a/sys-apps/fileutils/ChangeLog b/sys-apps/fileutils/ChangeLog
index 69f8140c78bd..598436d11ebb 100644
--- a/sys-apps/fileutils/ChangeLog
+++ b/sys-apps/fileutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/fileutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/ChangeLog,v 1.6 2002/07/14 19:20:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/ChangeLog,v 1.7 2002/09/25 14:29:50 azarah Exp $
+
+*fileutils-4.1.11 (25 Sep 2002)
+
+ 25 Sep 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Update version. Seems acl is included in this release.
*fileutils-4.1.8-r2 (04 May 2002)
diff --git a/sys-apps/fileutils/files/digest-fileutils-4.1.11 b/sys-apps/fileutils/files/digest-fileutils-4.1.11
new file mode 100644
index 000000000000..b693177a981b
--- /dev/null
+++ b/sys-apps/fileutils/files/digest-fileutils-4.1.11
@@ -0,0 +1 @@
+MD5 bb4c7625c96a4123d3dddde1a2cbcfa1 fileutils-4.1.11.tar.gz 2563888
diff --git a/sys-apps/fileutils/files/fileutils-4.1.11-configure.patch b/sys-apps/fileutils/files/fileutils-4.1.11-configure.patch
new file mode 100644
index 000000000000..4ceb4d462c4f
--- /dev/null
+++ b/sys-apps/fileutils/files/fileutils-4.1.11-configure.patch
@@ -0,0 +1,11 @@
+--- fileutils-4.1.11/configure.orig 2002-09-25 16:08:45.000000000 +0200
++++ fileutils-4.1.11/configure 2002-09-25 16:05:52.000000000 +0200
+@@ -33236,7 +33236,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ jm_cv_sys_struct_winsize_needs_sys_ptem_h=yes
+- if test $am_cv_sys_posix_termios = yes; then
++ if test "${am_cv_sys_posix_termios}" = yes; then
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
diff --git a/sys-apps/fileutils/fileutils-4.1.11.ebuild b/sys-apps/fileutils/fileutils-4.1.11.ebuild
new file mode 100644
index 000000000000..86f1d8d1d70a
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.1.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1.11.ebuild,v 1.1 2002/09/25 14:29:50 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix braindead scripting problem in configure
+ # <azarah@gentoo.org> (25 Sep 2002)
+ patch -p1 < ${FILESDIR}/${P}-configure.patch || die
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --bindir=/bin \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ bindir=${D}/bin \
+ install || die
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+
+ #conflicts with textutils. seems that they install the same
+ #.info file between the two of them
+ rm -f ${D}/usr/share/info/coreutils.info
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+