summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-12 02:05:14 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-12 02:05:14 +0000
commit76c998bf38b0ca0f5eb7cc435d1c6b53c68c096f (patch)
tree0cb0705ac612e60a0ef943c6fde44ac121556f62 /sys-apps/grep
parenttesting profile for amd64/uclibc (diff)
downloadhistorical-76c998bf38b0ca0f5eb7cc435d1c6b53c68c096f.tar.gz
historical-76c998bf38b0ca0f5eb7cc435d1c6b53c68c096f.tar.bz2
historical-76c998bf38b0ca0f5eb7cc435d1c6b53c68c096f.zip
dont use __mempcpy
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/Manifest8
-rw-r--r--sys-apps/grep/grep-2.5.1-r9.ebuild5
2 files changed, 8 insertions, 5 deletions
diff --git a/sys-apps/grep/Manifest b/sys-apps/grep/Manifest
index e680d09f95c4..263b3d75c7f5 100644
--- a/sys-apps/grep/Manifest
+++ b/sys-apps/grep/Manifest
@@ -17,12 +17,12 @@ MD5 f108b43aae8b2abc6326efa8ab44e8dd files/grep-2.5.1-oi.patch 1695
MD5 b6da5288895ddd97074deb10f48b4364 files/grep-2.5.1-perl-segv.patch 410
MD5 1eee743f3bf8a7926c07f9a0307a6b64 files/grep-2.5.1-restrict_arr.patch 410
MD5 c8c3f59f3fd000c41915a97ab0a5f2c5 grep-2.5.1-r8.ebuild 1884
-MD5 9f4506b314db51cebdd4eb95f02710ea grep-2.5.1-r9.ebuild 2146
+MD5 fb9b330865efa5e316be69bdeb002c61 grep-2.5.1-r9.ebuild 2206
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDvcNc2+ySkm8kpY0RAjtFAJ9EYhucR4vOVr2rDWUvCDbqOuFSKQCfS8qf
-hI+MFfeHHGi6nv8zYtrtBNk=
-=OP+m
+iD8DBQFDxbm52+ySkm8kpY0RAspxAKDHFHCfdXEeWJGEdAGd7vfldRsmUQCgo3uh
+eV4fJP4IVO59GZdQGcvbGYA=
+=ViCg
-----END PGP SIGNATURE-----
diff --git a/sys-apps/grep/grep-2.5.1-r9.ebuild b/sys-apps/grep/grep-2.5.1-r9.ebuild
index 5983f6aa3aff..c1ea8f5597bd 100644
--- a/sys-apps/grep/grep-2.5.1-r9.ebuild
+++ b/sys-apps/grep/grep-2.5.1-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r9.ebuild,v 1.5 2006/01/06 01:08:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r9.ebuild,v 1.6 2006/01/12 02:05:14 vapier Exp $
inherit flag-o-matic eutils
@@ -37,6 +37,9 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-libintl.patch #92586
epatch "${FILESDIR}"/${P}-fix-devices-skip.patch #113640
+ # retarded
+ sed -i 's:__mempcpy:mempcpy:g' lib/*.c || die
+
# uclibc does not suffer from this glibc bug.
use elibc_uclibc || epatch "${FILESDIR}"/${PV}-tests.patch
}