summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-30 21:40:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-30 21:40:11 +0000
commit88f3117a2e595710518987b4e4609a7b7fdf8eb8 (patch)
treeae671772c91c5cfa99a2e20f669b051c73de4235 /sys-apps/pcsc-lite/pcsc-lite-1.2.9_beta6.ebuild
parent~ia64 KEYWORDS (diff)
downloadhistorical-88f3117a2e595710518987b4e4609a7b7fdf8eb8.tar.gz
historical-88f3117a2e595710518987b4e4609a7b7fdf8eb8.tar.bz2
historical-88f3117a2e595710518987b4e4609a7b7fdf8eb8.zip
Version bump #69419 by Sebastian Spaeth.
Diffstat (limited to 'sys-apps/pcsc-lite/pcsc-lite-1.2.9_beta6.ebuild')
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.2.9_beta6.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.2.9_beta6.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.2.9_beta6.ebuild
new file mode 100644
index 000000000000..6feb184e2da6
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.2.9_beta6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.2.9_beta6.ebuild,v 1.1 2004/10/30 21:40:11 vapier Exp $
+
+inherit eutils
+
+NUM=753
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="https://alioth.debian.org/download.php/${NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="!static? ( virtual/libc dev-libs/libusb )"
+DEPEND="sys-devel/make
+ sys-devel/libtool
+ sys-apps/sed
+ sys-devel/flex
+ sys-apps/gawk
+ dev-libs/libusb
+ dev-util/pkgconfig
+ sys-devel/gcc
+ virtual/libc
+ dev-libs/libusb
+ >=sys-apps/portage-2.0.51"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --enable-usbdropdir=/usr/lib/readers/usb \
+ --enable-muscledropdir=/usr/share/pcsc/services \
+ $(use_enable static) \
+ || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog DRIVERS HELP INSTALL NEWS README SECURITY
+ dodoc doc/*.pdf doc/README.DAEMON
+ docinto sample
+ dodoc src/utils/README src/utils/sample.*
+ rm -rf ${D}/usr/doc
+
+ newinitd ${FILESDIR}/pcscd-init pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --soname libpcsclite.so.0'"
+}