summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-07-10 14:04:45 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-07-10 14:04:45 +0000
commit97147152fb68724ad1ad2eabbbf2f409e3be9505 (patch)
tree70a25d3026b26b53f39f9caa679731ba238673c0 /sys-apps/sandbox
parentchange to wrapper script (diff)
downloadhistorical-97147152fb68724ad1ad2eabbbf2f409e3be9505.tar.gz
historical-97147152fb68724ad1ad2eabbbf2f409e3be9505.tar.bz2
historical-97147152fb68724ad1ad2eabbbf2f409e3be9505.zip
Add some fixes to the getcwd implementation, bug #98419.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/ChangeLog8
-rw-r--r--sys-apps/sandbox/Manifest16
-rw-r--r--sys-apps/sandbox/files/sandbox-1.2.10-uclibc-getcwd.patch30
-rw-r--r--sys-apps/sandbox/files/sandbox-1.2.9-uclibc-getcwd.patch21
-rw-r--r--sys-apps/sandbox/sandbox-1.2.10.ebuild9
-rw-r--r--sys-apps/sandbox/sandbox-1.2.9.ebuild9
6 files changed, 79 insertions, 14 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 512378308578..038ccc5165f6 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.19 2005/07/05 06:12:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.20 2005/07/10 14:04:45 azarah Exp $
+
+ 10 Jul 2005; Martin Schlemmer <azarah@gentoo.org>
+ +files/sandbox-1.2.9-uclibc-getcwd.patch,
+ +files/sandbox-1.2.10-uclibc-getcwd.patch, sandbox-1.2.9.ebuild,
+ sandbox-1.2.10.ebuild:
+ Add some fixes to the getcwd implementation, bug #98419.
05 Jul 2005; Jeremy Huddleston <eradicator@gentoo.org>
sandbox-1.2.9.ebuild:
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 528d9983f6f0..0bf43eece21c 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 95005ec57007aeb8836ea5061ebb1d50 ChangeLog 3055
+MD5 697b6f10516558062dbdc6c98fccd751 sandbox-1.2.9.ebuild 2814
+MD5 561e7345b8bc9c92eb84128a26ec5190 ChangeLog 3299
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
-MD5 9577ed05c914f1f9af48c0013f86f9b0 sandbox-1.2.9.ebuild 2732
-MD5 712a227c38e91acbf46935ca02c8f9a8 sandbox-1.2.10.ebuild 2629
-MD5 0b9d8a3302f89af8fcb328f02eb16824 files/digest-sandbox-1.2.9 66
+MD5 b6cb0c2fe5437433eb8c5f24800b356d sandbox-1.2.10.ebuild 2715
+MD5 36e3d59477310a00b5b240377e4e47dd files/sandbox-1.2.10-uclibc-getcwd.patch 751
MD5 9fe5eef00b6290f1c9fb750c3bfc1fad files/digest-sandbox-1.2.10 67
+MD5 76e3fe575f6739c3a9de06eb2dcdd1ac files/sandbox-1.2.9-uclibc-getcwd.patch 508
+MD5 0b9d8a3302f89af8fcb328f02eb16824 files/digest-sandbox-1.2.9 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCyiTKArHZZzCEUG0RAjMpAJwI4c4LqPylWmo4GxVQaLDQbfwiPQCcCc8e
-qEibQatgVg2ZD9fmEcufaSw=
-=v4em
+iD8DBQFC0SuH1ZcsMnZjRyIRAk+pAJ41ItGYgrCoDNv50Dcq/ujjTnGiZgCghhhu
+uIkHFXOjEPdzh2O4d6c+Rk8=
+=hb71
-----END PGP SIGNATURE-----
diff --git a/sys-apps/sandbox/files/sandbox-1.2.10-uclibc-getcwd.patch b/sys-apps/sandbox/files/sandbox-1.2.10-uclibc-getcwd.patch
new file mode 100644
index 000000000000..2c538eec6f86
--- /dev/null
+++ b/sys-apps/sandbox/files/sandbox-1.2.10-uclibc-getcwd.patch
@@ -0,0 +1,30 @@
+Index: getcwd.c
+===================================================================
+--- getcwd.c (revision 125)
++++ getcwd.c (working copy)
+@@ -128,7 +128,7 @@
+ if (strlen(path_buf) + 4 > path_size) {
+ goto oops;
+ }
+- snprintf(path_buf, 4, "/..");
++ snprintf(path_buf + strlen(path_buf), 4, "/..");
+ if (recurser(path_buf, path_size, root_dev, root_ino) == 0)
+ return 0;
+
+@@ -146,6 +146,8 @@
+ struct stat st;
+ size_t olderrno;
+
++ if (lstat("/", &st) < 0)
++ return -1;
+ olderrno = errno;
+ len = -1;
+ cwd = recurser(buf, size, st.st_dev, st.st_ino);
+@@ -175,6 +177,7 @@
+ if (path == NULL)
+ return NULL;
+ }
++ snprintf(buf, 2, ".");
+ ret = __syscall_egetcwd(path, alloc_size);
+ if (ret >= 0)
+ {
diff --git a/sys-apps/sandbox/files/sandbox-1.2.9-uclibc-getcwd.patch b/sys-apps/sandbox/files/sandbox-1.2.9-uclibc-getcwd.patch
new file mode 100644
index 000000000000..8709d70d6d66
--- /dev/null
+++ b/sys-apps/sandbox/files/sandbox-1.2.9-uclibc-getcwd.patch
@@ -0,0 +1,21 @@
+Index: getcwd.c
+===================================================================
+--- getcwd.c (revision 125)
++++ getcwd.c (working copy)
+@@ -146,6 +146,8 @@
+ struct stat st;
+ size_t olderrno;
+
++ if (lstat("/", &st) < 0)
++ return -1;
+ olderrno = errno;
+ len = -1;
+ cwd = recurser(buf, size, st.st_dev, st.st_ino);
+@@ -175,6 +177,7 @@
+ if (path == NULL)
+ return NULL;
+ }
++ snprintf(buf, 2, ".");
+ ret = __syscall_egetcwd(path, alloc_size);
+ if (ret >= 0)
+ {
diff --git a/sys-apps/sandbox/sandbox-1.2.10.ebuild b/sys-apps/sandbox/sandbox-1.2.10.ebuild
index 61b5f80d5f5f..0c45f277cff5 100644
--- a/sys-apps/sandbox/sandbox-1.2.10.ebuild
+++ b/sys-apps/sandbox/sandbox-1.2.10.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.10.ebuild,v 1.1 2005/07/03 19:06:07 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.10.ebuild,v 1.2 2005/07/10 14:04:45 azarah Exp $
#
# don't monkey with this ebuild unless contacting portage devs.
# period.
#
-inherit eutils flag-o-matic eutils toolchain-funcs multilib
+inherit eutils flag-o-matic toolchain-funcs multilib
DESCRIPTION="sandbox'd LD_PRELOAD hack"
HOMEPAGE="http://www.gentoo.org/"
@@ -37,10 +37,13 @@ setup_multilib() {
src_unpack() {
setup_multilib
for ABI in $(get_install_abis) ; do
- unpack ${A}
cd ${WORKDIR}
+ unpack ${A}
einfo "Unpacking sandbox for ABI=${ABI}..."
mv ${S} ${S%/}-${ABI} || die "failed moving \$S to ${ABI}"
+ cd ${S%/}-${ABI}
+ # Fix getcwd, bug #98419.
+ epatch ${FILESDIR}/${P}-uclibc-getcwd.patch
done
}
diff --git a/sys-apps/sandbox/sandbox-1.2.9.ebuild b/sys-apps/sandbox/sandbox-1.2.9.ebuild
index 5e3a27ae0e90..da4f690a1f8f 100644
--- a/sys-apps/sandbox/sandbox-1.2.9.ebuild
+++ b/sys-apps/sandbox/sandbox-1.2.9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.9.ebuild,v 1.2 2005/07/05 06:12:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.9.ebuild,v 1.3 2005/07/10 14:04:45 azarah Exp $
#
# don't monkey with this ebuild unless contacting portage devs.
# period.
#
-inherit eutils flag-o-matic eutils toolchain-funcs multilib
+inherit eutils flag-o-matic toolchain-funcs multilib
DESCRIPTION="sandbox'd LD_PRELOAD hack"
HOMEPAGE="http://www.gentoo.org/"
@@ -38,10 +38,13 @@ setup_multilib() {
src_unpack() {
setup_multilib
for ABI in $(get_install_abis) ; do
- unpack ${A}
cd ${WORKDIR}
+ unpack ${A}
einfo "Unpacking sandbox for ABI=${ABI}..."
mv ${S} ${S%/}-${ABI} || die "failed moving \$S to ${ABI}"
+ cd ${S%/}-${ABI}
+ # Fix getcwd, bug #98419.
+ epatch ${FILESDIR}/${P}-uclibc-getcwd.patch
done
}