summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-29 13:12:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-29 13:12:55 +0000
commit2767286a67181316e8af3625b5d8894a214a2238 (patch)
tree9179d3693bc93dc62c1422ad5bc2b1557b1847f9 /sys-apps
parentadjusted DEPEND for hesiod (diff)
downloadhistorical-2767286a67181316e8af3625b5d8894a214a2238.tar.gz
historical-2767286a67181316e8af3625b5d8894a214a2238.tar.bz2
historical-2767286a67181316e8af3625b5d8894a214a2238.zip
version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lsof/ChangeLog10
-rw-r--r--sys-apps/lsof/files/digest-lsof-4.641
-rw-r--r--sys-apps/lsof/lsof-4.64.ebuild57
3 files changed, 67 insertions, 1 deletions
diff --git a/sys-apps/lsof/ChangeLog b/sys-apps/lsof/ChangeLog
index 9b62795e2c2b..9b3b0c9fec8a 100644
--- a/sys-apps/lsof/ChangeLog
+++ b/sys-apps/lsof/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/lsof
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.1 2002/02/01 21:53:37 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.2 2002/06/29 13:12:55 seemant Exp $
+
+*lsof-4.64 (29 Jun 2002)
+
+ 29 Jun 2002; Seemant Kulleen <seemant@gentoo.org> lsof-4.64.ebuild
+ files/digest-lsof-4.64 :
+
+ Version bump (old version's tarball does not even exist at SRC_URI).
+ thanks to: paidhi@mospheira.net in bug #4310
*lsof-4.60-r1 (1 Feb 2002)
diff --git a/sys-apps/lsof/files/digest-lsof-4.64 b/sys-apps/lsof/files/digest-lsof-4.64
new file mode 100644
index 000000000000..4556e583f594
--- /dev/null
+++ b/sys-apps/lsof/files/digest-lsof-4.64
@@ -0,0 +1 @@
+MD5 584b2d652f8703b6af0a21aa57b241d6 lsof_4.64.tar.gz 942463
diff --git a/sys-apps/lsof/lsof-4.64.ebuild b/sys-apps/lsof/lsof-4.64.ebuild
new file mode 100644
index 000000000000..779b8aba3959
--- /dev/null
+++ b/sys-apps/lsof/lsof-4.64.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.64.ebuild,v 1.1 2002/06/29 13:12:55 seemant Exp $
+
+MY_P=${P/-/_}
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+DESCRIPTION="Lists open files for running Unix processes"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.gz
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.gz"
+HOMEPAGE="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/README"
+
+DEPEND="virtual/glibc virtual/linux-sources"
+
+LICENSE="GPL-2"
+SLOT=""
+
+#This pkg appears to be highly kernel-dependent.
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/${MY_P}
+ tar xf ${MY_P}_src.tar || die
+}
+
+src_compile() {
+
+ #interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
+ #is there a way to avoid the "echo to a file + file read"?
+ #Just piping in the results didn't seem to work.
+ echo -e "y\ny\ny\nn\ny\ny\n" > ${T}/junk
+ ./Configure linux < ${T}/junk
+
+ #simple Makefile hack to insert CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" Makefile.orig > Makefile
+
+ make all || die
+}
+
+src_install () {
+
+ #/usr/sbin is a good location -- drobbins
+ dosbin lsof
+ # .a libs not needed during boot so they go in /usr/lib -- drobbins
+ dolib lib/liblsof.a
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+ doman lsof.8
+ local x
+ for x in 00*
+ do
+ newdoc ${x} ${x/00/}
+ done
+ cd ${D}/usr/share/doc/${PF}
+ mv .README.FIRST.gz README.FIRST.gz
+}
+