summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-02 14:51:48 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-02 14:51:48 +0000
commit4e0721fffcdc63dd43196fc543fcab81cc535011 (patch)
tree5c647c0d96acbec780e5e6c8df64baba711e54e7 /sys-apps
parentStable on alpha. (diff)
downloadhistorical-4e0721fffcdc63dd43196fc543fcab81cc535011.tar.gz
historical-4e0721fffcdc63dd43196fc543fcab81cc535011.tar.bz2
historical-4e0721fffcdc63dd43196fc543fcab81cc535011.zip
Only build/install languages as defined by $LINGUAS #97612 by Martin von Gagern.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/ChangeLog6
-rw-r--r--sys-apps/man/Manifest10
-rw-r--r--sys-apps/man/man-1.6.ebuild21
3 files changed, 25 insertions, 12 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 50ff432a663d..4ea0cd4df4a7 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.70 2005/07/01 00:04:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.71 2005/07/02 14:51:48 vapier Exp $
+
+ 02 Jul 2005; Mike Frysinger <vapier@gentoo.org> man-1.6.ebuild:
+ Only build/install languages as defined by $LINGUAS #97612 by Martin von
+ Gagern.
30 Jun 2005; Luca Barbato <lu_zero@gentoo.org>
+files/man-1.6-parallel-make.patch, man-1.6.ebuild:
diff --git a/sys-apps/man/Manifest b/sys-apps/man/Manifest
index bd4a150ecc0f..40ee63fd9489 100644
--- a/sys-apps/man/Manifest
+++ b/sys-apps/man/Manifest
@@ -3,8 +3,8 @@ Hash: SHA1
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 9c896566b39c57595f9b9c807aa05a00 man-1.5p.ebuild 2574
-MD5 f8110e4f866320bf931b4d71f43b2642 man-1.6.ebuild 2546
-MD5 b5a737a99f981150d0cd332039b15670 ChangeLog 10206
+MD5 630f1ea425178af59dd62c7c006dafaf man-1.6.ebuild 2685
+MD5 496f671cc0d84b89d1137083cdac730c ChangeLog 10358
MD5 90c01e3cfecc4bc92266780a9be71429 files/digest-man-1.6 59
MD5 80f2a25fb0b5692f39a1990527a93271 files/man-1.5m-groff-1.18.patch 923
MD5 14e1c7533927dfb89900ee788666b342 files/man-1.5p-defmanpath-symlinks.patch 663
@@ -16,7 +16,7 @@ MD5 7b2b00aace5bcdb963286e235eaf22b2 files/man-1.5p-search-order.patch 519
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCxIisgIKl8Uu19MoRAiHnAJ0XlnMFWJQkvSf6K5uGeWWTfEJmVACfX6oG
-bNLNBlmqq1HnUKKbm0QKjNM=
-=Hm+H
+iD8DBQFCxqorgIKl8Uu19MoRAs5gAJwNnhfSsWF0pdbp2HMw7va6pjCz5ACdEZaA
+apaplM4naXfYR8ejwWXwdUQ=
+=iAj3
-----END PGP SIGNATURE-----
diff --git a/sys-apps/man/man-1.6.ebuild b/sys-apps/man/man-1.6.ebuild
index 678538c20282..2c7bfe3f1cae 100644
--- a/sys-apps/man/man-1.6.ebuild
+++ b/sys-apps/man/man-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6.ebuild,v 1.3 2005/06/30 10:18:45 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6.ebuild,v 1.4 2005/07/02 14:51:48 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -23,18 +23,18 @@ src_unpack() {
cd "${S}"
# Make sure we can build with -j :)
- epatch ${FILESDIR}/man-1.6-parallel-make.patch
+ epatch "${FILESDIR}"/man-1.6-parallel-make.patch
# Fix search order in man.conf so that system installed manpages
# will be found first ...
- epatch ${FILESDIR}/man-1.5p-search-order.patch
+ epatch "${FILESDIR}"/man-1.5p-search-order.patch
# For groff-1.18 or later we need to call nroff with '-c'
- epatch ${FILESDIR}/man-1.5m-groff-1.18.patch
+ epatch "${FILESDIR}"/man-1.5m-groff-1.18.patch
# makewhatis traverses manpages twice, as default manpath
# contains two directories that are symlinked together
- epatch ${FILESDIR}/man-1.5p-defmanpath-symlinks.patch
+ epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
# use non-lazy binds for man. And let portage handling stripping.
append-ldflags -Wl,-z,now
@@ -48,7 +48,16 @@ src_compile() {
tc-export CC BUILD_CC
local myconf=
- use nls && myconf="+lang all" || myconf="+lang none"
+ if use nls ; then
+ strip-linguas $(cd man; echo ??)
+ if [[ -z ${LINGUAS} ]] ; then
+ myconf="+lang all"
+ else
+ myconf="+lang ${LINGUAS// /,}"
+ fi
+ else
+ myconf="+lang none"
+ fi
./configure \
-confdir=/etc \
+sgid +fhs \