summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-19 23:04:48 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-19 23:04:48 +0000
commit9895c03e9611095a40074a9afdebe6287b2331eb (patch)
tree93670517a6030d34fc9c4ea02068cd87b00b15f1 /sys-apps
parentold (diff)
downloadhistorical-9895c03e9611095a40074a9afdebe6287b2331eb.tar.gz
historical-9895c03e9611095a40074a9afdebe6287b2331eb.tar.bz2
historical-9895c03e9611095a40074a9afdebe6287b2331eb.zip
pkgconfig only goes in DEPEND #217278
Package-Manager: portage-2.2_pre5
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/blktool/blktool-4.ebuild7
-rw-r--r--sys-apps/irqbalance/irqbalance-0.55-r1.ebuild5
-rw-r--r--sys-apps/irqbalance/irqbalance-0.55-r2.ebuild5
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.8-r2.ebuild26
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.9_pre20050614.ebuild28
5 files changed, 39 insertions, 32 deletions
diff --git a/sys-apps/blktool/blktool-4.ebuild b/sys-apps/blktool/blktool-4.ebuild
index 67e0441e21d2..91c4f38bb135 100644
--- a/sys-apps/blktool/blktool-4.ebuild
+++ b/sys-apps/blktool/blktool-4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/blktool/blktool-4.ebuild,v 1.2 2008/01/10 13:45:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/blktool/blktool-4.ebuild,v 1.3 2008/04/19 23:00:21 vapier Exp $
DESCRIPTION="query and/or change settings of a block device"
HOMEPAGE="http://sourceforge.net/projects/gkernel/"
@@ -11,10 +11,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="=dev-libs/glib-2*
+RDEPEND="=dev-libs/glib-2*"
+DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/sys-apps/irqbalance/irqbalance-0.55-r1.ebuild b/sys-apps/irqbalance/irqbalance-0.55-r1.ebuild
index 24425e72ff08..82c67e5baf13 100644
--- a/sys-apps/irqbalance/irqbalance-0.55-r1.ebuild
+++ b/sys-apps/irqbalance/irqbalance-0.55-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-0.55-r1.ebuild,v 1.2 2008/01/14 16:40:13 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-0.55-r1.ebuild,v 1.3 2008/04/19 23:01:44 vapier Exp $
inherit eutils
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="=dev-libs/glib-2*
+RDEPEND="=dev-libs/glib-2*"
+DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_unpack() {
diff --git a/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild b/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild
index 3662c3806400..09a3722bfb1a 100644
--- a/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild
+++ b/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild,v 1.1 2008/04/15 06:08:35 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild,v 1.2 2008/04/19 23:01:44 vapier Exp $
inherit eutils
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="=dev-libs/glib-2*
+RDEPEND="=dev-libs/glib-2*"
+DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_unpack() {
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8-r2.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8-r2.ebuild
index a7a5430cabf6..4ce45336f8b0 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8-r2.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8-r2.ebuild,v 1.15 2007/07/22 06:24:05 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8-r2.ebuild,v 1.16 2008/04/19 23:04:48 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -11,19 +11,21 @@ SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm ppc sh x86"
-
IUSE="gtk vanilla trusted X xforms"
+
RDEPEND="!sys-apps/pcmcia-cs-cis
- !sys-apps/pcmcia-cs-pnptools
- X? ( x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libXaw
- gtk? ( =x11-libs/gtk+-2*
- dev-util/pkgconfig )
- xforms? ( x11-libs/xforms ) )"
+ !sys-apps/pcmcia-cs-pnptools
+ X? (
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXaw
+ gtk? ( =x11-libs/gtk+-2* )
+ xforms? ( x11-libs/xforms )
+ )"
DEPEND="${RDEPEND}
- virtual/linux-sources
- >=sys-apps/sed-4"
+ dev-util/pkgconfig
+ virtual/linux-sources
+ >=sys-apps/sed-4"
pkg_setup() {
linux-info_pkg_setup
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.9_pre20050614.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.9_pre20050614.ebuild
index 1f865c463261..0410486ad21b 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.9_pre20050614.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.9_pre20050614.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.9_pre20050614.ebuild,v 1.3 2007/07/22 06:24:05 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.9_pre20050614.ebuild,v 1.4 2008/04/19 23:04:48 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -15,20 +15,22 @@ SRC_URI="http://pcmcia-cs.sourceforge.net/ftp/NEW/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
-
IUSE="gtk vanilla trusted X xforms"
+
RDEPEND="!sys-apps/pcmcia-cs-cis
- !sys-apps/pcmcia-cs-pnptools
- X? ( x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libXaw
- gtk? ( =x11-libs/gtk+-2*
- dev-util/pkgconfig )
- xforms? ( x11-libs/xforms ) )"
+ !sys-apps/pcmcia-cs-pnptools
+ X? (
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXaw
+ gtk? ( =x11-libs/gtk+-2* )
+ xforms? ( x11-libs/xforms )
+ )"
DEPEND="${RDEPEND}
- virtual/linux-sources
- dev-util/yacc
- >=sys-apps/sed-4"
+ dev-util/pkgconfig
+ virtual/linux-sources
+ dev-util/yacc
+ >=sys-apps/sed-4"
pkg_setup() {
linux-info_pkg_setup