summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-07-01 05:43:23 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-07-01 05:43:23 +0000
commitff75e8a9a2b006b9638a1ab994b5232495630f21 (patch)
tree21b11e2f5486933b95672e0a907147e7aadf43fb /sys-apps
parentsoundtracker version bump and gnome-core dep removal (diff)
downloadhistorical-ff75e8a9a2b006b9638a1ab994b5232495630f21.tar.gz
historical-ff75e8a9a2b006b9638a1ab994b5232495630f21.tar.bz2
historical-ff75e8a9a2b006b9638a1ab994b5232495630f21.zip
meep
----------------------------------------------------------------------
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bzip2/bzip2-1.0.2-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/bzip2/bzip2-1.0.2-r2.ebuild b/sys-apps/bzip2/bzip2-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..c030c902bfa7
--- /dev/null
+++ b/sys-apps/bzip2/bzip2-1.0.2-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.2-r2.ebuild,v 1.1 2002/07/01 05:43:23 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v102/${P}.tar.gz
+ ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v102/${P}.tar.gz"
+HOMEPAGE="http://sourceware.cygnus.com/bzip2/"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ # for optimizations, we keep -fomit-frame-pointer and -fno-strength-reduce
+ # for speed. -fstrength-reduce seems to slow down the code slightly on x86.
+ # (drobbins)
+ sed -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
+ -e "s:-O2:${CFLAGS}:g" \
+ Makefile.orig > Makefile || die
+ cp Makefile-libbz2_so Makefile-libbz2_so.orig
+ sed -e "s:-O2:${CFLAGS}:g" \
+ Makefile-libbz2_so.orig > Makefile-libbz2_so || die
+}
+
+src_compile() {
+ if [ -z "`use build`" ]
+ then
+ emake -f Makefile-libbz2_so all || die
+ fi
+ emake all || die
+}
+
+src_install() {
+ if [ -z "`use build`" ]
+ then
+ make PREFIX=${D}/usr install || die
+ mv ${D}/usr/bin ${D}
+ dolib.so ${S}/libbz2.so.${PV}
+ dosym /usr/lib/libbz2.so.${PV} /usr/lib/libbz2.so.1.0
+ dosym /usr/lib/libbz2.so.${PV} /usr/lib/libbz2.so
+ dodoc README LICENSE CHANGES Y2K_INFO
+ docinto txt
+ dodoc *.txt
+ docinto ps
+ dodoc *.ps
+ dohtml manual_*.html
+ else
+ into /
+ dobin bzip2
+ cd ${D}/bin
+ ln -s bzip2 bunzip2
+ fi
+}
+
+