summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-27 12:10:18 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-27 12:10:18 +0000
commit3c5ed47b594aecbd5d2976338f03d1c4ed2a89e9 (patch)
tree38448fe1b68af7b0e168ad367d1bb55826e17a30 /sys-auth/fprintd
parentOnly respect LINGUAS if set (diff)
downloadhistorical-3c5ed47b594aecbd5d2976338f03d1c4ed2a89e9.tar.gz
historical-3c5ed47b594aecbd5d2976338f03d1c4ed2a89e9.tar.bz2
historical-3c5ed47b594aecbd5d2976338f03d1c4ed2a89e9.zip
Initial import
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'sys-auth/fprintd')
-rw-r--r--sys-auth/fprintd/ChangeLog10
-rw-r--r--sys-auth/fprintd/Manifest4
-rw-r--r--sys-auth/fprintd/fprintd-0.2.0.ebuild69
-rw-r--r--sys-auth/fprintd/metadata.xml9
4 files changed, 92 insertions, 0 deletions
diff --git a/sys-auth/fprintd/ChangeLog b/sys-auth/fprintd/ChangeLog
new file mode 100644
index 000000000000..f491e30deba6
--- /dev/null
+++ b/sys-auth/fprintd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-auth/fprintd
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/fprintd/ChangeLog,v 1.1 2010/10/27 12:10:18 xmw Exp $
+
+*fprintd-0.2.0 (27 Oct 2010)
+
+ 27 Oct 2010; Michael Weber <xmw@gentoo.org> +fprintd-0.2.0.ebuild,
+ +metadata.xml:
+ Initial import, fixes bug #341747 reported by Jan Buecken <jb.faq@gmx.de>.
+
diff --git a/sys-auth/fprintd/Manifest b/sys-auth/fprintd/Manifest
new file mode 100644
index 000000000000..e4601ef9ce39
--- /dev/null
+++ b/sys-auth/fprintd/Manifest
@@ -0,0 +1,4 @@
+DIST V_0_2_0.tar.bz2 43754 RMD160 8e6609e212106fa7cab0ce35802dd3eea5381504 SHA1 fd5c5f9fdcdb62a933269d3fa5c47afded56f5ba SHA256 173fc0f94ffc8605ea2f3051a6f943bfcab6c5295ea6951f5e18b6605f022ef6
+EBUILD fprintd-0.2.0.ebuild 1768 RMD160 db29e3f1ccf56a0e21b5badc197e627182f5ee54 SHA1 26a946d3a636720f533177960e3fc0f396640201 SHA256 90f83d0ac581438ed86abb1ac1be13779a9edc8b6bb7fde3402d796d471c4f9c
+MISC ChangeLog 396 RMD160 283d3c634f8482a43e2836df41a5588398337d06 SHA1 c759da5d43cfde4ff7aa29b9313a607d0ade5287 SHA256 509997484a9df2ebb54925f15c23777ac59c828fcc1ca696dddef89a7f8f7938
+MISC metadata.xml 244 RMD160 ba31bc851ce5d8e007b223b4f799d84d4c6699d0 SHA1 2192e855054fb7016488afba3eda6d938fdf925d SHA256 1022f65be1952b5197408dfbf61543b61557601ce3a9f15acabeb3e9d84a0fbe
diff --git a/sys-auth/fprintd/fprintd-0.2.0.ebuild b/sys-auth/fprintd/fprintd-0.2.0.ebuild
new file mode 100644
index 000000000000..feb944b19452
--- /dev/null
+++ b/sys-auth/fprintd/fprintd-0.2.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/fprintd/fprintd-0.2.0.ebuild,v 1.1 2010/10/27 12:10:18 xmw Exp $
+
+EAPI=3
+
+inherit autotools toolchain-funcs versionator
+
+DESCRIPTION="D-Bus to offer libfprint functionality"
+HOMEPAGE="http://cgit.freedesktop.org/libfprint/fprintd/"
+MY_PV="V_$(replace_all_version_separators _)"
+SRC_URI="http://cgit.freedesktop.org/libfprint/${PN}/snapshot/${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc pam static-libs"
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ sys-auth/libfprint
+ sys-auth/polkit
+ pam? ( sys-libs/pam )
+ "
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/intltool
+ doc? ( dev-libs/libxml2 dev-libs/libxslt )
+ "
+
+S=${WORKDIR}/${MY_PV}
+
+src_prepare() {
+ cp /usr/share/gtk-doc/data/gtk-doc.make . || die
+ sed -e '/SUBDIRS/s: po::' -i Makefile.am || die
+ eautoreconf
+ intltoolize || die
+}
+
+src_configure() {
+ econf $(use_enable pam) \
+ $(use_enable static-libs static) \
+ $(use_enable doc gtk-doc-html)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ pammoddir=/$(get_libdir)/security || die
+
+ keepdir /var/lib/fprint || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+ if use doc ; then
+ insinto ${EPREFIX}/usr/share/doc/${PF}/html
+ doins doc/{fprintd-docs,version}.xml || die
+ insinto ${EPREFIX}/usr/share/doc/${PF}/html/dbus
+ doins doc/dbus/net.reactivated.Fprint.{Device,Manager}.ref.xml || die
+ fi
+}
+
+pkg_postinst() {
+ elog "You can add the following line to your /etc/pam.d/system-auth"
+ elog
+ elog " auth sufficient pam_fprintd.so"
+ elog
+ elog "to enable the PAM module for authentication."
+ elog "But don't lock yourself out, keep one terminal open!"
+}
diff --git a/sys-auth/fprintd/metadata.xml b/sys-auth/fprintd/metadata.xml
new file mode 100644
index 000000000000..32c2cb560368
--- /dev/null
+++ b/sys-auth/fprintd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>