summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-11-23 06:06:23 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-11-23 06:06:23 +0000
commita3932a0cab13c63838d1cf298f28b5ce405f3c6f (patch)
treebb2e74a14a92eee8af29fc6fcdcf123e5f0e9924 /sys-auth/policykit/policykit-0.6.ebuild
parentBug #190128 - Add a blocker for <sys-apps/portage-2.1.4_rc1 so that we (diff)
downloadhistorical-a3932a0cab13c63838d1cf298f28b5ce405f3c6f.tar.gz
historical-a3932a0cab13c63838d1cf298f28b5ce405f3c6f.tar.bz2
historical-a3932a0cab13c63838d1cf298f28b5ce405f3c6f.zip
initial import of policykit for HAL 0.5.10
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'sys-auth/policykit/policykit-0.6.ebuild')
-rw-r--r--sys-auth/policykit/policykit-0.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-auth/policykit/policykit-0.6.ebuild b/sys-auth/policykit/policykit-0.6.ebuild
new file mode 100644
index 000000000000..f9450136f4f3
--- /dev/null
+++ b/sys-auth/policykit/policykit-0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/policykit/policykit-0.6.ebuild,v 1.1 2007/11/23 06:06:22 compnerd Exp $
+
+inherit eutils autotools multilib
+
+MY_PN="PolicyKit"
+
+DESCRIPTION="Policy framework for setting user allowed actions with priviledge"
+HOMEPAGE="http://hal.freedesktop.org/docs/PolicyKit"
+SRC_URI="http://hal.freedesktop.org/releases/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc selinux"
+
+RDEPEND=">=dev-libs/glib-2.7
+ >=dev-libs/dbus-glib-0.61
+ virtual/pam
+ dev-libs/expat
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/pkgconfig
+ app-text/docbook-xsl-stylesheets
+ doc? ( dev-util/gtk-doc )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ enewgroup polkituser || die "failed to create group"
+ enewuser polkituser -1 "-1" /dev/null polkituser || die "failed to create user"
+}
+
+src_compile() {
+ econf --with-expat \
+ --with-pam-module-dir=/$(get_libdir)/security \
+ --with-os-type=gentoo \
+ $(use_enable doc gtk-doc) \
+ $(use_enable selinux) \
+ --with-polkit-user=polkituser \
+ --with-polkit-group=polkituser \
+ --localstatedir=/var \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # Need to keep a few directories around...
+ keepdir /var/run/PolicyKit
+ keepdir /var/lib/PolicyKit
+}