summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-02 22:51:22 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-02 22:51:22 +0000
commit1ba0cc7aa0d67ba9041ad62595c8b94d52104fe0 (patch)
tree57ae0b02225679aca0ef2d4d04965c7d1bb45bda /sys-boot/elilo/elilo-3.4-r3.ebuild
parentStore user-settings file for later use by future versions of pyode. (diff)
downloadhistorical-1ba0cc7aa0d67ba9041ad62595c8b94d52104fe0.tar.gz
historical-1ba0cc7aa0d67ba9041ad62595c8b94d52104fe0.tar.bz2
historical-1ba0cc7aa0d67ba9041ad62595c8b94d52104fe0.zip
Stabilize -r2 with vapier's ebuild updates, but bump it to -r3 at the same
time to push out repaired sample elilo.conf Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-boot/elilo/elilo-3.4-r3.ebuild')
-rw-r--r--sys-boot/elilo/elilo-3.4-r3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-boot/elilo/elilo-3.4-r3.ebuild b/sys-boot/elilo/elilo-3.4-r3.ebuild
new file mode 100644
index 000000000000..9122ed1ae534
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.4-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4-r3.ebuild,v 1.1 2005/08/02 22:51:22 agriffis Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://elilo.sourceforge.net/"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/elilo-3.4-makefile.patch
+ epatch "${FILESDIR}"/elilo-3.4-proc-sigsetjmp.patch
+ epatch "${FILESDIR}"/elilo-3.3a-devscheme.patch
+}
+
+src_compile() {
+ local iarch
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+}
+
+src_install() {
+ newsbin "${FILESDIR}"/elilo-${PV} elilo || die "elilo failed"
+ dosbin tools/eliloalt || die "eliloalt failed"
+
+ exeinto /usr/lib/elilo
+ doexe elilo.efi || die "elilo.efi failed"
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ newman "${FILESDIR}"/elilo.8-${PV} elilo.8
+ newman "${FILESDIR}"/eliloalt.8-${PV} eliloalt.8
+}