summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-21 19:22:52 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-21 19:22:52 +0000
commit99b8ff6c6f78cb24bafb6e4e3e894f2656845bde (patch)
treeac541739da06e9ad22008ba1b1ea4c99c3ee90a4 /sys-boot/grub/grub-9999.ebuild
parentReplace local+export with "local -x". (diff)
downloadhistorical-99b8ff6c6f78cb24bafb6e4e3e894f2656845bde.tar.gz
historical-99b8ff6c6f78cb24bafb6e4e3e894f2656845bde.tar.bz2
historical-99b8ff6c6f78cb24bafb6e4e3e894f2656845bde.zip
Let configure auto-detect efiemu support.
Package-Manager: portage-2.2.0_alpha188/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'sys-boot/grub/grub-9999.ebuild')
-rw-r--r--sys-boot/grub/grub-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index edd09828326e..23dc08e48f09 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.95 2013/07/21 00:37:11 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.96 2013/07/21 19:22:48 floppym Exp $
EAPI=5
AUTOTOOLS_AUTO_DEPEND=yes
@@ -181,13 +181,15 @@ grub_configure() {
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
$(use_enable debug mm-debug)
$(use_enable debug grub-emu-usb)
- $(use_enable efiemu)
$(use_enable mount grub-mount)
$(use_enable nls)
$(use_enable truetype grub-mkfont)
$(use_enable libzfs)
$(use sdl && use_enable debug grub-emu-sdl)
${platform:+--with-platform=}${platform}
+
+ # Let configure detect this where supported
+ $(usex efiemu '' --disable-efiemu)
)
if use multislot; then