summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFriedrich Oslage <bluebird@gentoo.org>2008-06-12 20:33:52 +0000
committerFriedrich Oslage <bluebird@gentoo.org>2008-06-12 20:33:52 +0000
commitfeee3fedcd971700454d3c929c60dec4362a380c (patch)
treece2b3fad7835a2e6b2770e9e3a4453a55e4353a3 /sys-boot/silo/files
parentMarking libvorbis-1.2.1_rc1 ppc64 for bug 222085 (diff)
downloadhistorical-feee3fedcd971700454d3c929c60dec4362a380c.tar.gz
historical-feee3fedcd971700454d3c929c60dec4362a380c.tar.bz2
historical-feee3fedcd971700454d3c929c60dec4362a380c.zip
Add a patch to make it work with gcc 4.3
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-boot/silo/files')
-rw-r--r--sys-boot/silo/files/gcc-4.3-compile.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-boot/silo/files/gcc-4.3-compile.patch b/sys-boot/silo/files/gcc-4.3-compile.patch
new file mode 100644
index 000000000000..74c37558553e
--- /dev/null
+++ b/sys-boot/silo/files/gcc-4.3-compile.patch
@@ -0,0 +1,20 @@
+--- silo.orig/second/Makefile
++++ silo/second/Makefile
+@@ -58,13 +58,13 @@
+ $(AR) rc $@ $(FS_OBJS)
+
+ second: $(OBJS) mark.o
+- $(LD) $(LDFLAGS_SMALL) -Bstatic -o second $(OBJS) -lext2fs mark.o
+- $(LD) $(LDFLAGS_LARGE) -Bstatic -o second2 $(OBJS) -lext2fs mark.o
++ $(LD) $(LDFLAGS_SMALL) -Bstatic -o second $(OBJS) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
++ $(LD) $(LDFLAGS_LARGE) -Bstatic -o second2 $(OBJS) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
+ $(NM) second | grep -v '*ABS*' | sort > second.map
+
+ silotftp: $(OBJSNET) mark.o
+- $(LD) $(LDFLAGS_SMALL) -Bstatic -o silotftp $(OBJSNET) -lext2fs mark.o
+- $(LD) $(LDFLAGS_LARGE) -Bstatic -o silotftp2 $(OBJSNET) -lext2fs mark.o
++ $(LD) $(LDFLAGS_SMALL) -Bstatic -o silotftp $(OBJSNET) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
++ $(LD) $(LDFLAGS_LARGE) -Bstatic -o silotftp2 $(OBJSNET) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
+ $(NM) silotftp | grep -v '*ABS*' | sort > silotftp.map
+
+ second.l: second