summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2012-02-24 15:18:55 +0000
committerJoseph Jezak <josejx@gentoo.org>2012-02-24 15:18:55 +0000
commit7b4e8b28ba719d0cff9d65ef0990c51a2b8e6eb9 (patch)
treea8c76dc99d55089567bb78a0e58eb0f4ca261457 /sys-boot/yaboot/files
parentx86 stable wrt bug #400329 (diff)
downloadhistorical-7b4e8b28ba719d0cff9d65ef0990c51a2b8e6eb9.tar.gz
historical-7b4e8b28ba719d0cff9d65ef0990c51a2b8e6eb9.tar.bz2
historical-7b4e8b28ba719d0cff9d65ef0990c51a2b8e6eb9.zip
Version bump.
Package-Manager: portage-2.1.10.46/cvs/Linux x86_64
Diffstat (limited to 'sys-boot/yaboot/files')
-rw-r--r--sys-boot/yaboot/files/yaboot-1.3.17-nopiessp-gcc4.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-boot/yaboot/files/yaboot-1.3.17-nopiessp-gcc4.patch b/sys-boot/yaboot/files/yaboot-1.3.17-nopiessp-gcc4.patch
new file mode 100644
index 000000000000..8e060e54c2e8
--- /dev/null
+++ b/sys-boot/yaboot/files/yaboot-1.3.17-nopiessp-gcc4.patch
@@ -0,0 +1,42 @@
+diff -Nrup yaboot-1.3.13.orig/Config.gentoo yaboot-1.3.13/Config.gentoo
+--- yaboot-1.3.13.orig/Config.gentoo 1970-01-01 00:00:00.000000000 +0000
++++ yaboot-1.3.13/Config.gentoo 2005-06-12 00:41:14.889576152 +0000
+@@ -0,0 +1,6 @@
++check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
++ then echo "$(1)"; else echo "$(2)"; fi)
++
++CFLAGS += $(call check_gcc, -fno-stack-protector)
++CFLAGS += $(call check_gcc, --nopie)
++
+diff -Nrup yaboot-1.3.13.orig/Makefile yaboot-1.3.13/Makefile
+--- yaboot-1.3.13.orig/Makefile 2004-07-11 20:12:03.000000000 +0000
++++ yaboot-1.3.13/Makefile 2005-06-12 00:41:14.890576000 +0000
+@@ -1,6 +1,7 @@
+ ## Setup
+
+ include Config
++include Config.gentoo
+
+ VERSION = 1.3.13
+ # Debug mode (spam/verbose)
+@@ -79,7 +80,7 @@ HOSTCFLAGS = -O2 $(CFLAGS) -Wall -I/usr/
+ second/fs_of.o second/fs_ext2.o second/fs_iso.o second/fs_swap.o \
+ second/iso_util.o \
+ lib/nonstd.o \
+- lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o
++ lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o lib/ssp.o
+
+ ifeq ($(USE_MD5_PASSWORDS),y)
+ OBJS += second/md5.o
+diff -Naur yaboot-1.3.14.orig/lib/ssp.c yaboot-1.3.14/lib/ssp.c
+--- yaboot-1.3.14.orig/lib/ssp.c 1970-01-01 00:00:00.000000000 +0000
++++ yaboot-1.3.14/lib/ssp.c 2010-06-20 18:50:57.000000000 +0000
+@@ -0,0 +1,7 @@
++extern void __stack_chk_fail_local (void) ;
++
++void
++__stack_chk_fail_local (void)
++{
++ return;
++}
+