summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-10 00:41:33 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-10 00:41:33 +0000
commitfdf8d687fef18c321aa36287a500329af6a7f574 (patch)
tree022671022eca9b01a8fdcda56ee0dd736b865dce /sys-boot
parentnew release (diff)
downloadhistorical-fdf8d687fef18c321aa36287a500329af6a7f574.tar.gz
historical-fdf8d687fef18c321aa36287a500329af6a7f574.tar.bz2
historical-fdf8d687fef18c321aa36287a500329af6a7f574.zip
Version bump.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/Manifest10
-rw-r--r--sys-boot/syslinux/files/digest-syslinux-3.051
-rw-r--r--sys-boot/syslinux/syslinux-3.05.ebuild33
4 files changed, 46 insertions, 5 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 81717492cc67..84e7dee53ba6 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.12 2005/01/10 00:32:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.13 2005/01/10 00:41:33 vapier Exp $
+
+*syslinux-3.05 (09 Jan 2005)
+
+ 09 Jan 2005; Mike Frysinger <vapier@gentoo.org> +syslinux-3.05.ebuild:
+ Version bump.
*syslinux-2.13 (09 Jan 2005)
diff --git a/sys-boot/syslinux/Manifest b/sys-boot/syslinux/Manifest
index e5f723f0adc0..f9b608eaedc6 100644
--- a/sys-boot/syslinux/Manifest
+++ b/sys-boot/syslinux/Manifest
@@ -1,18 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 93eb2e823d64b6f469c9ef5d93a2c73d ChangeLog 3260
+MD5 62d2af0417d41279016cf94369cb3db0 ChangeLog 3380
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 53ae1668c8fc16cc1e0093f28b1511a2 syslinux-2.13.ebuild 963
MD5 be91e91e8fbb5560f3cbd9adc6a38677 syslinux-2.11.ebuild 959
+MD5 49d73d05c1ccbf4262aa53905cbc0c29 syslinux-3.05.ebuild 960
MD5 fad406869474fc3a7cfde4203eb896fe syslinux-1.76.ebuild 760
MD5 26489361fe682baf353e4b7cef7bba16 files/digest-syslinux-1.76 65
MD5 d44d8f9a65b91ec75463ccc8dd60cee3 files/digest-syslinux-2.13 66
+MD5 798848c65e6e488d942399422a4155c9 files/digest-syslinux-3.05 66
MD5 437dcea1ca8e2c9469874b045a9e76cb files/digest-syslinux-2.11 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.14 (GNU/Linux)
-iD8DBQFB4c1GroRuSHgZdywRAi6zAJ4x4P/c+nzOHChi9WVFdGskQorACACeOPnj
-T3ei3wLKTBAqxKduL3v4mY8=
-=WOef
+iD4DBQFB4c9SroRuSHgZdywRAgQRAJoDuyShWrAWpZNIsiJb7Qm4R/NTxACYn+sJ
+uGYQvYFu2fD9cZ+/zPOklg==
+=Mjqg
-----END PGP SIGNATURE-----
diff --git a/sys-boot/syslinux/files/digest-syslinux-3.05 b/sys-boot/syslinux/files/digest-syslinux-3.05
new file mode 100644
index 000000000000..eec143bad5b7
--- /dev/null
+++ b/sys-boot/syslinux/files/digest-syslinux-3.05
@@ -0,0 +1 @@
+MD5 78cb7cdbc5307c8acde324288bd3a5dc syslinux-3.05.tar.bz2 518449
diff --git a/sys-boot/syslinux/syslinux-3.05.ebuild b/sys-boot/syslinux/syslinux-3.05.ebuild
new file mode 100644
index 000000000000..b0f5118fbbd1
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.05.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.05.ebuild,v 1.1 2005/01/10 00:41:33 vapier Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}