summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-09 14:32:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-09 14:32:13 +0000
commit1954c0f75bfded6724f59ae976061ae299067bd1 (patch)
tree431b850b1dd681d5be0781caa1b9bfad36caa540 /sys-cluster/pbs-python
parentUpdate tarball to not use screwed one released by upstream. Revbump to force ... (diff)
downloadhistorical-1954c0f75bfded6724f59ae976061ae299067bd1.tar.gz
historical-1954c0f75bfded6724f59ae976061ae299067bd1.tar.bz2
historical-1954c0f75bfded6724f59ae976061ae299067bd1.zip
Use Python 2.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'sys-cluster/pbs-python')
-rw-r--r--sys-cluster/pbs-python/Manifest12
-rw-r--r--sys-cluster/pbs-python/pbs-python-4.1.0.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/sys-cluster/pbs-python/Manifest b/sys-cluster/pbs-python/Manifest
index 30f4a76f5cdf..fc4c4396c9da 100644
--- a/sys-cluster/pbs-python/Manifest
+++ b/sys-cluster/pbs-python/Manifest
@@ -1,14 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
DIST pbs_python-4.1.0.tar.gz 150403 RMD160 51d7e40a4f0ef53b8873158e122e7683688891c1 SHA1 5b1b216d53745b81c85ff8b3a7ae5b2f7096b0de SHA256 ccc31531e0c1f113892e2e5d7e8abb7a0f07402a297f5d82d07235631838acc2
-EBUILD pbs-python-4.1.0.ebuild 739 RMD160 492a359d069d488820ec4ad49151403f75801fc9 SHA1 dd80365215920157c0cb0adf11b24403ec6dfeb1 SHA256 41aa84d020a1f98177780faf4df932b6d54300809f0975dc1ea3d2e7d1377671
+EBUILD pbs-python-4.1.0.ebuild 807 RMD160 80c45c70d8f349a035a63ac59378e70c31c3fa07 SHA1 f0f63ce9d0a4685dea5a74c9550f2d3c0b704654 SHA256 93242407beaad16cbc28a3305cb9fde8fb91451920763707b57276f952c92b19
MISC ChangeLog 954 RMD160 700c5f67b510901239b4167419bb886d0409fd8f SHA1 f68633958a57a6af6a6a266b7795f2fff3a5cf16 SHA256 b0fa8995836d2e4650adc7efae2b3428aebbc961305255619a6ef4fe5e4ca37b
MISC metadata.xml 163 RMD160 ea1530cd45b9e04e8693261b9a94b5988e4b09a1 SHA1 443b7a3d8fb76c8d20647b165032ad358bfa3b6a SHA256 5a03bf3074b07158dffe793af69f7b0cd1e5c785537574713f9a7978032363a3
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.14 (GNU/Linux)
-
-iEYEARECAAYFAkwO+qMACgkQ4MrvBE1wQ8lgCgCgmJZxVEpmgiZJzajoaiv8H9Mn
-S5wAoJ4yDEqO/RjXHg+VtLVe6z27uoDl
-=uopZ
------END PGP SIGNATURE-----
diff --git a/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild b/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
index 76557bbaf9fb..65cfab7bf380 100644
--- a/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
+++ b/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
@@ -1,24 +1,34 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild,v 1.1 2010/06/09 02:19:25 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild,v 1.2 2010/06/09 14:32:13 arfrever Exp $
EAPI=3
PYTHON_DEPEND="2"
PYTHON_MODNAME="pbs"
+
inherit distutils
MY_P=${P/-/_}
+
DESCRIPTION="Python bindings to the Torque C API"
HOMEPAGE="https://subtrac.sara.nl/oss/pbs_python/"
SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${MY_P}.tar.gz"
+
LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64"
IUSE="examples"
+
RDEPEND="sys-cluster/torque"
DEPEND="${RDEPEND}"
+
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
distutils_src_install
if use examples; then