summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-05-07 21:26:31 +0000
committerMichael Imhof <tantive@gentoo.org>2003-05-07 21:26:31 +0000
commit9a5123aa06db69855a3a8155bfaa40e802bbf20b (patch)
tree1de2bd8b809e98b334ef1eeba95deb9fb097b9d9 /sys-cluster
parentVersion bumped. (diff)
downloadhistorical-9a5123aa06db69855a3a8155bfaa40e802bbf20b.tar.gz
historical-9a5123aa06db69855a3a8155bfaa40e802bbf20b.tar.bz2
historical-9a5123aa06db69855a3a8155bfaa40e802bbf20b.zip
Changed openmosixcollector-initscript. Should close #20481
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmosix-user/ChangeLog7
-rw-r--r--sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r31
-rw-r--r--sys-cluster/openmosix-user/openmosix-user-0.3-r3.ebuild92
3 files changed, 99 insertions, 1 deletions
diff --git a/sys-cluster/openmosix-user/ChangeLog b/sys-cluster/openmosix-user/ChangeLog
index 75ecec07a63a..294c725e9d22 100644
--- a/sys-cluster/openmosix-user/ChangeLog
+++ b/sys-cluster/openmosix-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/openmosix-user
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/ChangeLog,v 1.10 2003/05/02 09:41:05 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/ChangeLog,v 1.11 2003/05/07 21:26:31 tantive Exp $
+
+* openmosix-user-0.3.-r3 (07 May 2003)
+
+ 07 May 2003; Michael Imhof <tantive@gentoo.org>
+ Changed the openmosixcollector init script. Should close #20481
* openmosix-user-0.3.-r2 (02 May 2003)
diff --git a/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r3 b/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r3
new file mode 100644
index 000000000000..02794b6db342
--- /dev/null
+++ b/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r3
@@ -0,0 +1 @@
+MD5 bc3b686cafe591a8207fc6c39c36ba6f openmosix-tools-0.3.tgz 143737
diff --git a/sys-cluster/openmosix-user/openmosix-user-0.3-r3.ebuild b/sys-cluster/openmosix-user/openmosix-user-0.3-r3.ebuild
new file mode 100644
index 000000000000..1d41dd2a3d4a
--- /dev/null
+++ b/sys-cluster/openmosix-user/openmosix-user-0.3-r3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/openmosix-user-0.3-r3.ebuild,v 1.1 2003/05/07 21:26:31 tantive Exp $
+
+S=${WORKDIR}/openmosix-tools-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openmosix-tools-${PV}.tgz"
+HOMEPAGE="http://www.openmosix.com/"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.18"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ dev-lang/perl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+
+pkg_setup() {
+ if [ -z "`readlink /usr/src/linux|grep openmosix`" ]; then
+ eerror
+ eerror "Your linux kernel sources do not appear to be openmosix,"
+ eerror "please check your /usr/src/linux symlink."
+ eerror
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat > configuration << EOF
+
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\${OPENMOSIX}/include -I${S}/moslib ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+}
+
+src_compile() {
+ cd ${S}
+ make clean build
+}
+
+src_install() {
+ dodir /bin
+ dodir /sbin
+ dodir /usr/share/doc
+ dodir /usr/share/man/man1
+ make INSTALLDIR=${D}/usr \
+ MANDIR=${D}usr/share/man \
+ SYSCONFDIR=${D}/etc \
+ BINDIR=${D}/bin \
+ SBINDIR=${D}/sbin \
+ RCDIR=${D}/etc/init.d \
+ LIBDIR=${D}/usr/lib \
+ install
+
+ dodoc COPYING README
+ rm ${D}/etc/init.d/openmosix
+ rm ${D}/etc/init.d/openmosixcollector
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ newexe ${FILESDIR}/openmosixcollector.init openmosixcollector
+ insinto /etc
+ rm ${D}/etc/openmosix.map
+ #Test if mosix.map is present, stub appropriate openmosix.map
+ #file
+ if test -e /etc/openmosix.map; then
+ einfo "Seems you already have a openmosix.map file, using it.";
+ elif test -e /etc/mosix.map; then
+ cp /etc/mosix.map ${WORKDIR}/openmosix.map;
+ doins ${WORKDIR}/openmosix.map;
+ else
+ doins ${FILESDIR}/openmosix.map;
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/openmosix.map or"
+ einfo " delete it to use autodiscovery and then type:"
+ einfo " # rc-update add openmosix default"
+ einfo " ...to add openMosix to the default runlevel. This particular version of"
+ einfo " openmosix-user has been designed to work with the linux-2.4.18-openmosix-1"
+ einfo " or later kernel (>=sys-kernel/openmosix-sources-2.4.18)"
+ einfo
+}